4

Parallels Dekstop 13.0.1 BE won't let me add a Physical Internal HDD to the VM system.

There is a SATA HardDrive in my system with a GPT partition table and a big (2TB) NTFS partition. I use it when normally booted in a Microsoft Windows installation located in another drive. The disk contains some user files and a few apps. There is no OS installed on it. The hard drive is recognized and works as expected under macOS too.

Please note: macOS (10.12.6) is installed on a third disk. I also cannot update: I had to downgrade because High Sierra breaks compatibility with some stuff I have and I don't like the root login without password thingie.

My VM is actually a proper Windows 10 installation on an SSD which Parallels sees as Bootcamp and it works fine both natively and in the VM. In the VM settings though if I try to add a HDD it asks me what kind of drive I wish to attach. I can either create a new/use an existing virtual drive or use a "real" Hard Drive (Bootcamp). Problem is, only the SSD is seen as an available disk (the one with Windows installed on it) while my 2TB data disk does not appear.

I guess that is because it's not a Bootcamp/Windows hard drive, only a common disk with some files on it. I tried moving my pre-owned license and installing Paragon NTFS on this machine. Again, the Drive works as expected, I can view/move/edit/create/delete/rename files on it but Parallels still won't let me select the drive as an additional disk for my VM?

TL;DR and core question

What can I do to make my internal disk appear as a Bootcamp hard drive (preferably without actually installing Windows on it)?

Or, if impossible, how can I at least convince Parallels that my HDD is eligible for use as a VM drive?

  • Anyone at least have an idea? – Manchineel Dec 19 '17 at 12:48
1

A late reply to this, hopefully you have already found a solution. Just because I was having a similar issue getting my Windows install on an external SSD to recognise the internal SATA drive in the iMac. For me it was because the AHCI/SATA controller would fail with an error 10 and after much testing with driver updates etc I believe I found a solution.

The problem for seems to be do with how the drive is formatted / partition table as whenever I do so with Disk Utility then Windows fails to load it. However this was not the case when the bootcamp partition was on the internal drive or even when Windows booted from the external drive but still had a Windows partition on the internal one.

As Windows setup can see the internal drive during installation then you could use this format a partition created as FAT32 in OS X, which is pretty much what Bootcamp creates. That or just use the Bootcamp Assistant to create the partition and instead of going through with installing Windows stop after the part where you format the destination as NTFS.

  • But macOS reads and writes to the drive just fine. Also, it's a data disk, not a Windows installation. – Manchineel Apr 30 '18 at 22:02
  • Hmm I see not quite the same problem, as it sounds like its from the OS X side through VM settings that it won't let you add another drive. My situation is similar except not using a VM and OS X can work with the drive just fine...although from the times I ran bootcamp as a VM from the USB HDD I dont recall seeing the internal drive either. Is this what you are doing? download.parallels.com/desktop/v12/docs/ko_KR/… – o0XLR80o May 25 '18 at 13:18
  • Also with my situation, what I wrote above sadly didn't work in the end...I narrowed down the problem to OS X doing something to the partition map perhaps on each boot, and I was unable to stop it doing so or figure out what. If I just stay on Windows the disk will be fine between restarts. – o0XLR80o May 25 '18 at 13:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .