1

I followed this video instruction https://youtu.be/eFHvIrdm9So to add a second, SSD harddisk (OWC brand) to a mid 2011 iMac.

After the installation is complete I rebooted the machine and tried to install using a usb thumbdrive with High Sierra installation image.

The usb thumbdrive is prepared by running the following command:

sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyThumbDrive

However after the reboot, the drive is not visible in the disk utility.

Reboot again and use the original harddisk. The SSD is still not visible.

How can I fix it?

1

I find out the following solution at the end

1) Run PRAM by holding Option+Command+P+R at boot

2) Boot into macOS from the original harddisk

3) A message should appear and say there is an uninitialised harddisk

4) Use the disk utility to format the harddisk. In my case since the OS is still at Sierra, only HFS+ options are available.

5) Reboot and select the usb installation image of High Sierra

6) The SSD drive is now visible to the installer. Proceed with installation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .