7

I've got an iMac running High Sierra, and over the last couple of months it has developed a problem where it spontaneously reboots itself about once a day.

The reboots always occur when the iMac is asleep and the pattern is always the same. When the reboot happens, the startup chime happens twice in close succession. The error message is always like this:

Date/Time:       2017-12-10 08:43:57 -0800
OS Version:      Mac OS X 10.13.1 (Build 17B1003)
Architecture:    x86_64
Report Version:  26

Data Source:     Stackshots

Event:           Sleep Wake Failure
Duration:        0.05s
Steps:           5

Hardware model:  iMac13,2
Active cpus:     4

Time Awake Since Boot: 33000s

I researched Sleep Wake Failure on Ask Different and elsewhere on the web. I tried several things, including:

  • Energy Saver: Prevent computer from sleeping automatically when the display is off
  • Reset PRAM/NVRAM
  • Reset SMC

This iMac is getting a little old and it is quite possible a problem has developed with the hardware, but I do recall this started around the time I installed High Sierra and I've been assuming it's a correctable software problem.

Model info: iMac13,2, BootROM IM131.010F.B00, 4 processors, Intel Core i5, 2.9 GHz, 8 GB, SMC 2.11f14 Graphics: NVIDIA GeForce GTX 660M, NVIDIA GeForce GTX 660M, PCIe, 512 MB RAM 8 GB

  • 1
    Anyone have a fix yet? The High Sierra update has given me the same issue of the Sleep Wake Failure as well as dropping my wireless connection on and off constantly. I was hopeful that the 10.13.3 update fixed these known issues, but no. Very frustrating! – Kelly Riesberg Feb 7 '18 at 22:49
  • Is this problem fixed for you? – daniel Azuelos Jul 11 '18 at 21:17
  • Actually I do have an update. Recently I moved to a new house. Immediately the spontaneous reboots stopped happening. Same computer, same cords, same peripherals, same everything, except new house. This has me thinking now that it may have been some sort of power surges or brownouts relating to the electrical system in the old place. It's the only thing that seems to make sense. It's not a solution, but I hope this helps. – robbpriestley Jul 12 '18 at 4:09
  • Is it also possible there is an important difference in your network environment between these 2 locations? For example: WI-Fi in one nd not the other, Bluetooth in one and not the other, Ethernet connection in one place and Wi-Fi in the other? My hypothesis is that this wake failure may be related to a bad managment of power consumption. – daniel Azuelos Jul 30 '18 at 11:46
  • Yes, definitely possible but I do not suspect it as I used the identical network environment and equipment (Wifi router) both before and after the move. – robbpriestley Jul 30 '18 at 15:06
2

I have seen some reports of this same issue, with your same MacOS version. The below (one of them, or a combination of the two) solved this issue for most:

• Disable ‘Power Nap’

• ‘Wake for ethernet network access’

Please tell me if this resolved this for you!

—Mark

  • 3
    Power Nap and Wake for Ethernet Access are already both disabled. – robbpriestley Dec 11 '17 at 14:10
  • 3
    I have the same problem and this didn't work either – SaudiBombsYemen Jan 23 '18 at 13:41
  • I think that the 2nd change: "Wake for ethernet network access" avoid the sleeping state which is where the problem occurs. This is not fixing the problem but rather hiding it. – daniel Azuelos Jul 30 '18 at 11:55
0

I had the same problem on a brand new MacBook Pro, and I fixed it by choosing:

  • Disable Power Nap
  • Enable Prevent computer from sleeping automatically when the display is off

It ended up using a lot more power though, so if battery life is not an issue for you, try this.

  • 1
    Power Nap is already disabled so that's not it, and although preventing sleep would most likely correct the problem, poor power management is not an acceptable solution for me either. – robbpriestley Feb 9 '18 at 3:00

You must log in to answer this question.

protected by Community Feb 7 '18 at 23:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .