5

My macOS High Sierra install keeps switching to 720p HiDPI in stead of running at the native 1440p.

When I click on the 1440p setting it shows me the correct res but it switches back after about 1 second. When I reboot my Mac I also log in with the correct res but it changes to HiDPI after ~5 seconds.

The monitor is from Asus, 27" 2560x1440.

I tried changing the res with SwitchResX and jhford's screenresolution utility.

Display settings

9

I found a way to disable this behaviour through the this command:

sudo defaults write /Library/Preferences/com.apple.windowserver DisplayResolutionEnabled -bool NO

  • 1
    Thanks so much for finding this. I was banging my head against the wall for a few hours with tons of other posts and suggestions and this solved my issue. – Darthchai May 6 '18 at 7:46
  • Just tested on Mojave 10.14.2! You might want to edit Q or A to match MacOS names and versions and improve this post's relevance in search results. Great solution. – Marco Jan 18 at 16:49
0

If it's a VMWare one, when its active go to VM/settings/display/ then uncheck the "Automaticaly adjust user interface in the virtual machine" setting.

-1

high sierra gives you the option to let the system switch between the two gpu's automatically depending on what it decides is the right one for the situation. you can disable this by going to system preferences - then to energy saver. in the top left corner is a box you can tick or untick with the option to let high sierra decide to use automatic graphics switching or not. hope that helps.

  • I don't understand what this has to do with the question. The asker does not mention having two GPU's. – Wowfunhappy Feb 15 at 2:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .