8

So I have this issue when trying to reinstall macOS in the recovery, but when I tried to reinstall "Could not create a preboot volume for APFS install" comes up.

I came across this solution which requires you to completely wipe your drive but I don't want to do that since that would mean my BootCamp installation would also have to be gone.

Is there a way to fix this issue without completely wiping my disk?

2

For some odd reason, running the installer off a bootable flash drive solved the issue (as suggested here.)

I created the bootable flash drive using Install Disk Creator (DiskMaker X seems to have some trouble with High Sierra), booted onto it using Startup Manager by holding down Option at boot time, and then proceeding as normal with the install.

  • I guess the "odd reason" likely comes down to how much partitioning and messing can be done on the disk you booted from. – MarcH Nov 14 '18 at 17:50
  • @MarcH Probably. Still strange given that Recovery is an entirely Apple-sanctioned way of doing things. – JMY1000 Nov 14 '18 at 17:55
  • It is a non-obvious and annoying limitation but I wouldn't go as far as calling it "strange". For instance there could be some Apple EFI limitation relative to where on the disk it wants the Preboot partition to be found. Or maybe there some other, unknown and ancient tool that expects the location of the Preboot partition to be hardcoded to some specific place and the installer doesn't want to break backward compatibility. Or maybe the partitions skills of the recovery image are just too limited. – MarcH Nov 27 '18 at 17:17
2

If somebody face the same issue please consider to visit this link. https://www.belightsoft.com/products/resources/apfs-bootable-clone-with-command-line

I faced this issue when i converted HPS+ to APFS manually via DiskUtil. My MacBook was completely dead.

Bless utility is looking for APFS Preboot volume and because it is missing it fails to configure APFS container.

What i've done is:

  1. Boot to Recovery
  2. go to Terminal
  3. check partitions/disk numbers with diskutil list (preboot volume was missing for my APFS container )
  4. create Preboot volume manually with diskutil apfs addVolume disk"Disk Number here" apfs Preboot -role B
  5. and then bless the APFS container again with bless --folder /Volumes/MACINTOSH HD/System/Library/CoreServices --bootefi --verbose
  6. bless again via Startup Disk ( just to be sure)
  7. reboot
  • Worked without steps 5 and 6. Thanks for sharing! – sunknudsen Jul 21 '19 at 18:07
  • solved my problem as well – Infinity Dec 20 '19 at 1:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .