2

This question already has an answer here:

three weeks ago I've installed macOS High Sierra on my MacBook Pro 13" (Early 2015). I've an internal SSD with about 120 GB (Apple Logic) disk space. Before the update I had about 30 GB of space lost. But after the update it seems that some of the disk space is "lost" or got filled with some random crap.

This is a screenshot that shows the information about my Macintosh HD (the text is in german): enter image description here

As you can see the overview tells me, that there are about 28.38 GB free space with the information, that 21.36 GB can be deleted. So my first question is what can be deleted? After some googling I found out, that these are files that were not really needed because they can be downloaded or found somewhere in the cloud. But at the moment it's not clear to me which files are really meant.

I first recognized the problem when I wanted to download the latest version of Xcode and the AppStore.app told me that there is not enough disk space and I've to clean up my disk.

I've then also checked the complete usage of my disk: enter image description here

As you also can see, the app shows me that the system requires about 88.14 GB disk space, which cuts me really off. For what is this disk space needed?

I've checked my personal data and as you can see I've only a few programs installed and the needed disk space of my personal data is also really low: enter image description here

enter image description here

The most space is taken by all the developer tools. My personal data like images, etc. were stored on a SD card.

When I run df -h in iTerm2 it tells me that in fact only 6.4 GB are left on my disk and it also shows me that there are many TimeMachine backup snapshots left on my disk. Normally TimeMachine stores the backups on an external usb hard drive: enter image description here

So my question is, how can I get my disk space back and why is the system using so much space?

marked as duplicate by Mark, Allan, fsb, Tetsujin, Steve Chambers Jun 8 '18 at 20:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I'm running high Sierra on an old iMac. My system is shown as 88.31 GB. I don't know if that's correct either. – jmh Dec 9 '17 at 21:21
  • sanitize your local tm snapshots: sudo tmutil thinlocalsnapshots / size urgency (e.g sudo tmutil thinlocalsnapshots / 10000000000 4). Check man tmutil! Looks like a bug or an inconsisteny in/of TM & APFS... – klanomath Dec 9 '17 at 23:32
  • @klanomath Thanks I've tried that but that didn't change anything. I've also tried to delete the local snapshots manually with sudo tmutil deletelocalsnapshot <date>. But the snapshots are still there if i call df -h. – Fabian Dec 10 '17 at 8:05
  • I think it dumps the time machine snapshots onto the time machine disk when it next connects. Do a backup and restart, see if that helps. – Harv Dec 10 '17 at 11:16
  • what is name of the time machine files. An early questioner had many GB of files named com.apple.TimeMachine.<date>. Those can be removed with tmutil. – jmh Dec 16 '17 at 1:11
1

I had a similar problem. I ran 'dd' to fill up the SSD and then deleted the files afterwards:

dd if=/dev/zero of=/tmp/zero.1.out bs=1048576 count=10240

I created a few of those (10GB each and some larger - 30 GB) until the SSD was nearly 100% full.

I then deleted the files with: rm /tmp/zero.*.out

Finally: df -h / now reports the correct allocation with one oddity: ifree read 9223372036854041010 which seems incorrect.

Disk Utility (First Aid) was not picking up any issue although the reported available space was clearly off by 50 GB (almost 50% of the entire capacity of my SSD partition).

Hope this helps.

0

The first step in disk space questions is to power down the mac and then restart to another OS (bootable installer, internet recovery, recovery HD) and run Disk Utility. This verifies that the accounting is correct and you have good foundation to then remeasure and then take action.

In your case - the snapshots don't take any substantial space since that is all added up in the white diagonal line shaded part. A small fraction and you can get that exact value hovering your mouse over it just to the left of the white space on the right.

Next - system allocation in yellow covers all the user data for other users on the Mac - you might need to log in to each user one by one to pick apart how much space each user's home folder takes or resort to a tool like DaisyDisk to really read as an administrator how much space is in each home folder.

Apple's tools work well in many situations, but yours not so much. You did all the things proper in looking at app sizes, user data, etc..

Next steps for you is to use Finder and turn on Calculate all sizes in the View menu - Show View Options - Command + J

Finder View Options

Then start taking note of which folders on the computer are large and diving in to them.

Or get a third party tool.

Or use some command line options like ncdu or just du and appropriate invocation of admin/root privileges using sudo du

0

I have same problem. I would get the app DaisyDisk and run it on your Mac. It displays an image map of your disk drive and makes it very easy to spot which folders/fines are taking up so much space. I ran it and found out my system folder was only 9 GB, not 89. The app is available from the app store for $9.99. If you go to their website, here they have a free trial app.

There is a similar app, GrandPerspective, which is free.

Not the answer you're looking for? Browse other questions tagged .