7

I am an ordinary QWERTZ keyboard user. Now, when I setup my mac, I neglected the Keyboard Layout setting (I thought it would default to the usual). But, the layout was set to ABC - Extended.

I can change it back to QWERTZ, but every time I restart my mac it reverts back to the ABC setting.

My keyboard does not look like this (But part of me does wish it did).

abc layout

How can I permanently change the setting of the keyboard layout at the login screen? default setting

After updating to macOS Mojave I still have this problem, so the setting must have slipped back in through my TimeMachine backup.

The screen in macOS Mojave. There are some weird UI issues with Dvorak - QUERTY ⌘.

weird screen

This are my Language and Region settings:

regional settings

And my user settings: user settings

The problem persisted after I have updated to macOS Catalina.

These are my keyboard settings: keyboard settings

Update:

I could shed some light onto this issue. The ctrl.blog, which was mentioned in the comments mentions that FileVault might plays a role in this. So these are the steps I did follow:

  1. Reboot
  2. "ABC - Extended" is chosen as the language at the login dialog
  3. Choose German and sign in
  4. Reboot
  5. "ABC - Extended" is chosen as the language at the login dialog
  6. Change the language and sign in
  7. Disable FileVault and wait for it's completion
  8. Reboot
  9. The Loginscreen looks a bit different now, I'm able to scroll with the mouse wheel and I'm able to choose "Remove current from list" in the language menu.
  10. Sign in and Reboot
  11. FINALLY: The language is now still set to German.
  12. Enable FileVault again (hoping that the currently set language will be used as the new Default).
  13. Wait until FileVault is activated (another few hours)
  14. Reboot
  15. There we go again: ABC is again set as the default

I did submit this Feedback to Apple as of November 13 2019.

  • Is your keyboard connected to your Mac through a USB hub? Could you provide the keyboard manufacturer and model? – jaume Oct 6 '18 at 14:20
  • I have an apple usb keyboard and the builtin keyboard of my macbook – Besi Oct 6 '18 at 17:48
  • And you plug the USB keyboard directly to your Mac, I guess? To rule out that this issue is caused by the USB keyboard, if you set the keyboard layout to QWERTZ with the USB keyboard unplugged, restart and log in (without plugging in the keyboard), does the keyboard layout for the built-in keyboard revert to 'ABC - extended'? – jaume Oct 6 '18 at 18:48
  • @jaume, The ABC shows up as a default even when no external keyboard is connected. I always change the layout to German before I sign in (because I can't sign in otherwise). – Besi Oct 10 '18 at 21:34
  • 2
    Tried this fix already? – klanomath Nov 12 '19 at 13:31
1
+200

I wrote an article called How to fix macOS startup keyboard layout not persisting about this very problem.

I never figured out exactly what the problem was, but the ABC Extended keyboard layout is the default fallback when no other keyboard layout is configured. The pre-boot environment stores its settings separately from the rest of the system.

Sometimes these settings go out of sync, or the system fails to save settings to the pre-boot environment. You’re more likely to run into this when using FileVault disk-encryption because of the increased complexity in this setup.

I lay out 11 steps in the above article that gets macOS to regenerate the settings file in the pre-boot environment. With the help of my readers, I’ve identified at least three different problems that these steps can resolve. It’s easier to just diligently follow all the steps exactly than to first try to identify the exact issue and then try to fix it.

  • Thanks for your remarks. May I suggest to quote those eleven steps in your answer in case the link might break in the future. – Besi Nov 13 '19 at 13:07
0

If you don't use ABC - Extended or any other keyboard layout, you can simply remove them permanently from your list of keyboards.

  1. Go to Settings > Keyboard > Input Sources
  2. Select the keyboard you want to remove
  3. Click the - icon at the bottom

solution-pic

  • 1
    There I have "Swiss German" like expected. ABC does not show up there. I would think that this is a per-user setting. Where the login screen is a system wide setting, since the user has not signed in yet. – Besi Oct 10 '18 at 21:32
-2

Follow these steps:

https://support.apple.com/en-us/HT202036

We Dvorak folk have to do this all the time...

  • 1
    This did not work, I changed the language to "German" and ABC is still shown as the default afer a reboot. – Besi May 15 '19 at 8:09
  • Sigh. Sorry...sometimes even the official answer doesn't work... – Wilfred Smith May 15 '19 at 20:16
  • I did do this and the language was changed on the next reboot, however the keyboard-layout was still set to "ABC". :-( – Besi Nov 12 '19 at 12:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .