I have been using my iPhone 7 plus as a personal hotspot since I bought it. The hotspot worked fine with IOS 10. After upgrading my iPhone to IOS 11, the personal hotspot now exhibits the following behavior: It lets one or more devices connect to the personal hotspot but will not forward DNS requests to the internet. All web pages show "unable to connect". If I had a browser open to web pages prior to connecting the computer to the iPhone's hotspot, those webpages can still be browsed because the system cached the IP address of the site's domain.

This happens regardless whether I connect via wireless, Bluetooth, or USB. If I turn off the personal hotspot and turn it back on, all devices easily reconnect, but the behavior repeats: no DNS requests go through. It does not matter whether the tethered device is a laptop, tablet or IOT device. The behavior is the same.

I've done all of the usual folk-remedy "fixes" like restarting the phone, resetting network settings, recreating the hotspot name & password, and so forth with no change. I've hard-coded google's DNS servers into the DNS settings of the IP4 and IP6 network settings into the laptop with no success.

Any point in the right direction would be appreciated.

  • 1
    Can you please confirm that this is definitely a DNS issue? Let's have you go to 172.217.3.196 (one of Google's IPs), then tether and reload the page and put in a search, and see if that works. If it does, we can safely assume it is a DNS issue, in which case we can proceed to running a traceroute and seeing if it might be a port-blocking issue. – Harv Dec 8 '17 at 23:17
  • @Harv. Of course, as I try, tethering starts to behave. It's done this (behave) once before and was then followed a long drought of malfunction. When it starts to misbehave again - and it will - I'll perform that test and leave another comment. Thanks in advance for being patient. – Jim M Dec 11 '17 at 19:39

I have a similar problem with my Android phone, the working fix that I googled up was to edit manually APN settings and assure that "APN type" for APN used for data traffic reads "default,supl,dun". (It had been "default,supl")

New contributor
Ilya Ts. is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.