3

All other websites work and can be quickly accessed, even youtube.com will load. google.com will simply not load at all when I try to connect to it over cellular data. It does work over Wi-Fi, however. I tried using a different browser, the Google app, restarting the iPhone, everything. Funny thing though, the Google feed loads in the Google app, yet I cannot search with google within the app.

  • Who's your ISP? – JMY1000 Dec 6 '17 at 5:25
  • I’m using cellular, but yeah it’s T-Mobile. – user2738184 Dec 7 '17 at 22:26
3

This sounds like it may be an issue with your mobile service provider's DNS. I would try to Reset Network Settings to see if that clears out the cached DNS results.

To reset network settings: Tap SettingsGeneral > Reset > Reset Network Settings

  • This should work but it somehow doesn’t. I’m running iOS 11.2 on an iPhone X model A1865. I have to use bing while on the car lol – user2738184 Dec 7 '17 at 22:29
  • that is crazy, considering you're on new hardware / software maybe it's a bug with a newer release. Did it happen immediately after an update? I'm thinking it has something to do with DNS not clearing or with the DNS of your provider in your region. – OneSimpleGeek Dec 8 '17 at 21:35
  • I don't know if this is specifically the issue, but after I uninstalled the T-Mobile app, reset the network settings, then rebooted, Google started working. I was confused because I tried the SIM card on someone else's phone (A1865) and it worked for them. However, this is still a really weird bug considering it's literally T-Mobile's phone app. – user2738184 Dec 10 '17 at 0:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .