I’m using the createinstallmedia utility to create a bootable volume on an external 4TB USB drive. This drive has 6 partitions (some encrypted) on it, all of them are JHFS+, 1 is being used as the boot volume. The drive successfully boots a MacBook Pro 2015. When holding down the option key during startup, I can see the external drive and successfully boot from it. If I try to boot a Mac Mini 2012 using the same process, I don’t see the external drive. If I try to set the startup volume using System Preferences > Startup disk, the drive appears as an option, however upon restart, it fails to boot from the external volume.

Here’s the odd bit. If I format the drive as a single 4TB volume, use createinstallmedia to make it bootable, it will boot the Mac Mini 2012. If I then resize the drive using Disk Utility, create some partitions, both normal and encrypted, it still boots the Mac Mini. If I then use createinstallmedia again over the top of the existing boot volume, it no longer boots the mac Mini. It will boot the Mac Book Pro.

I have a limited knowledge of bless, but tried bless --folder "/Volumes/EXT/System/Library/CoreServices" --bootinfo --bootefi as per the man page. No Success.

I also tried reducing the amount of partitions, from 6 to 5. That ended up booting the Mac Mini. Curiously, adding the 6th partition back again gave a successful boot, where the previous 6 partition configuration failed.

Ideally I’d like to be able to easily use createinstallmedia to create an install drive for different versions of macOS, 10.11, 10.12, 10.13, across different hardware, from this 4TB drive.

Has anybody else come across these kind of issues with booting from a 4TB drive?

1 Answer 1


I just experienced a similar, though non-identical, issue with my own 2012 Mac Mini which failed to start-up from a bootable High Sierra installer on a 64GB multi-boot flash drive. The drive is formatted with bootable installer partitions for 10.6/10.8/10.9/10.10/10.11/10.12/10.13/blank. I, too, was able to view all the partitions as start-up drive options, but the Mini refused to actually boot from any of them. And recovery mode’s reinstaller was forcing the internal start-up SSD to reformat as AFPS, which I did not want. I put the Mini in target disk mode & connected it to my MacBook Air & the Air to the flash drive & used Terminal on the Air to install HFS+ High Sierra on the Mini. So, my take is that the issue is likely not related to details of the boot drive or its partitions but to something innate in the 2012 Mac Mini, itself.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .