I updated to High Sierra on my Macbook Pro when it was released. Since I have updated, a lot of my applications show the attached icon when I open them. Does anyone know a fix to this?

enter image description here

  • 1
    Can you give some examples of the applications that are showing the icon? A screen shot perhaps? – Allan Dec 5 '17 at 22:30
  • There should be a screenshot of the icon attached to the post. The problem seems to be unrelated to the apps being used and are seemingly random. – aj062819 Dec 6 '17 at 0:19
  • 2
  • 1
    sudo requires an admin password – Tetsujin Dec 6 '17 at 18:58
  • 1
    Would the admin password be the local computer admin or another admin? I used my admin password and was unsuccessful still. – aj062819 Dec 7 '17 at 5:23

Give this a try.

sudo find /private/var/folders/ -name com.apple.iconservices -exec rm -rf {} \;
sudo rm -rf /Library/Caches/com.apple.iconservices.store
killall Dock

After running the commands, I had to remove the app from the dock and add it again. It worked for me but YMMV.

| improve this answer | |
  • Worked like a charm. – ruby_newbie Mar 19 '18 at 0:06

Rebooting in "Safe Mode" fixes this issue. Probably because system caches are cleared and re-created during safe boot.

To boot in Safe Mode, hold the shift key while starting or rebooting the Mac. You can release the shift key when the login prompt appears.

Apple provides more details about Safe Mode in this article.

| improve this answer | |

This is what I did, but it resets your dock to default and removes every app expect the default ones:

$ defaults delete com.apple.dock
$ killall Dock

Don't know if it lasts long but I got all the icons back.

| improve this answer | |
  • This kills the settings of my dock, and the icons don't still come back. – ctc chen Oct 3 '18 at 3:54

Do you have the game "League of Legends" installed on your Mac ?

Other persons having this problem have reported that the update process of League of Legend may cause this issue.

If so, please upvote this issue on the LoL forum, to report it to developers : https://boards.na.leagueoflegends.com/en/c/bug-report/rA0p1rYx-client-updating-on-mac-high-sierra-messes-up-other-application-icons

| improve this answer | |

I had the same problem - reboot your mac in safe mode and then it will resolve itself

| improve this answer | |
  • This fixed the problem for me initially (icons on the dock were not missing after rebooting in safe mode and rebooting a second time), but later on when re-opening applications the issue has re-emerged. – Puhlze Dec 15 '17 at 15:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .