4

I have a MacBook Pro running High Sierra. Sometimes when I let my computer auto-lock itself, (like closing the lid for a while) when I come back the user is not the profile I was using, but says System Administrator and has the default grey silhouette icon. Using my TouchID logs me in as usual, so as far as I can tell it is just an aesthetics glitch. I also can't replicate it, because it seems to happen at random.

I've seen the news about the root user security issue and I'm updated to 10.13.1 so it shouldn't be related to that. Any ideas on what is happening? I will be updating as I experiment more with the issue.

Update 3: Still occurring. The root password will not provide access when the System Administrator icon shows up. As far as I can tell it is a purely aesthetic glitch.

Update 2: Following another thread I was able to enable the root user and give it a secure password. I will give any updates if the problem persists.

Update [added picture]: I haven't changed any passwords since this is a brand new laptop (2 weeks old). I've had the issue occur again and have determined it does require the proper password or touch ID; it won't let just anybody in. Also, it goes to the correct user every time. As far as I can tell, the name and icon are just swapped with the current user for some reason. I can only hope apple fixes this in the future because it is a bit disconcerting the first time it comes up.

  • I'd recommend updating, changing your passwords. Even for the root user. And then seeing if the issue persists. – Melvin Jefferson Dec 5 '17 at 16:56
1

macOS High Sierra Version 10.13.2 which came out this weekend appears to have removed this issue.

Well something changed somewhere because I haven't had this issue come up in the last 2 weeks. It doesn't correspond to any updates or changes as far as I can tell, but I'm considering this solved because the issue has disappeared.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .