3

Yesterday the SSD in my 13" mid-2012 MacBook Pro died. I replaced the old one with a new one.

First I tried to reinstall macOS with my Time Machine backup, but it failed. Then I tried to install a fresh copy from Internet Recovery Mode, that failed too. My last resort was to make a bootable USB on another Mac and install it that way. At first it seemed to work, but when it boots the drive does not show up as bootable.

I tried running Apple Hardware Check, but could not access it. It just showed a folder with a question mark.

Is there anything left to do?

  • Did you check the drive is formatted GUID/HFS+ ? Drives usually arrive MBR – Tetsujin Dec 5 '17 at 15:00
  • Yes I did, even tried to reformat it a couple of times. – Esben Kamstrup Mortensen Dec 5 '17 at 15:02
  • 2
    Maybe the SATA cable... they're a potential weakness [might even have been the actual cause of the initial failure]. You can run AHT from a USB stick, btw, see github.com/upekkha/AppleHardwareTest for links & method. – Tetsujin Dec 5 '17 at 15:05
2

Alright, I found out what the problem was. I was talking to a local IT-guy, he said, that SSDs from than manufactor, ADATA, wouldn't work with macOS. So the only solution was to buy another one.

-1

I would use that other Mac to make an OS installer. There are utilities that will take an installer and write it to a USB drive (8GB or greater) so that it can boot from that drive and install macOS. There is also a terminal command that will do the same thing. A little Google-fu will point you to those procedures.

Note that installing macOS on a drive and then putting that drive in another Mac does not always result in a drive that is bootable on both. Installers, however will boot any Mac that is capable of running that version of macOS. That is the path I would take

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .