5

After installing High Sierra, whenever I lock and close my MacBook Pro (2015), all my programs have quit once I open it again. Chrome will often show an "unexpectedly closed" message, which seems to indicate that it was not a graceful logout but a sudden forced quit of all programs.

It doesn't happen if I lock the computer and immediately unlock - only, apparently, if I close the laptop and come back after a while (sometimes as little as 5-10 minutes).

Why would this be happening?

High Sierra also freezes for around 5 seconds when I try to Lock the computer before actually locking, which is extremely slow and did not happen in Sierra.

I tried to ask this on Apple forums and got the message: "You are not allowed to create or update this content."

Additional info: - I'm running latest version of macOS (10.13.1). - When I unlock the Mac after this kind of mass-crash I often get the Optimizing Your Mac notification - It just happened to me again after closing the laptop for about 2 minutes - Twice today, instead of a mass crash, the Mac has just displayed a black screen (though the keyboard lights are on) and I was forced to restart. (This also happened intermittently with Sierra but not usually 2x in one day.)

  • 1
    You mentioned that you are running macOS 10.13.1. I would suggest that you update to macOS 10.13.2 and see if the issue is resolved. – Jake3231 Dec 14 '17 at 16:59
  • @Jake3231Thanks, tried this - after the upgrade I'm still getting the mass crashes. – Luke Williams Dec 16 '17 at 16:32
  • Thank you. Good to know. Are you using a 15" 2015 MacBook Pro or a 13"? – Jake3231 Dec 16 '17 at 16:48
  • @Jake3231 "Retina 15-Inch mid-2015" – Luke Williams Dec 16 '17 at 17:13
  • Thank you. Does your Mac have two graphics cards. This may be an Intel integrated GPU as well as a dedicated GPU. – Jake3231 Dec 16 '17 at 18:01
0

While I'm not entirely certain that this is the issue, you could attempt to disable graphics switching on your Mac.

In System Preferences, open the Energy Saver pane. From there, uncheck "Automatic Graphics Switching". To learn more about how to do that, check here: Set graphics performance on MacBook Pro

Note that disabling this setting will cause the discreet graphics to always be on. This may use more energy, but if this resolve the issue it would be helpful to know for troubleshooting.

  • Trying this and will see the results in next couple days, thank you. – Luke Williams Dec 20 '17 at 17:20
  • Unfortunately it just happened again the first time I locked and closed my computer, so it looks like that graphics setting wasn't the solution. – Luke Williams Dec 20 '17 at 21:08
  • Thank you for testing that. I would advise you run EtreCheck and update your question with the results. – Jake3231 Dec 20 '17 at 23:27
  • I ran it for "apps crashing." Report available here pastebin.com/Bw2HrwDR, I removed one piece of adware but didn't see anything else alarming. (Chrome was running a video at the same time which I suppose would account for the high CPU usage.) – Luke Williams Dec 22 '17 at 16:02
  • 1
    Thank you for uploading that report. I would suggest you just update all of your software and maybe remove the kernel extensions if you are not using them. – Jake3231 Dec 22 '17 at 17:09
0

After some experimentation I've found I can work around this issue by allowing the screen to fully lock before closing the laptop.

Locking is taking my Macbook around 5-10 seconds which seems pretty crazy considering it was new last year; however this situation is much preferable to all my programs having crashed every time I open it.

  • Update: about a week later, I've confirmed that waiting for my laptop to fully lock before closing it solves the issue and all my programs don't crash. There must be some bugged conflict when closing the laptop while Locking is still in progress. – Luke Williams Jan 2 '18 at 16:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .