2

I tried the following, but at each one except the single user mode, it is stuck on the white screen. This problem occurred after I shut down the MacBook Pro using power button after the screen froze

I tried booting from external USB, CMD+R, CMD+OPTION+R, OPTION,

While it is stuck at white screen it overheats, and sometimes restarts

I cannot reinstall MacOS or enter recovery or internet recovery or even erase the hard disk because it always ets stuck at the white screen.

Is there any way to fix it using terminal at single user mode?

  • Can you boot in Verbose Mode (Cmd-V) while booting? You may want to record to boot message so you can review/post them here. – Allan Dec 4 '17 at 16:50
  • I see en2: promiscuous mode enable succeeded, before it moves to grey/white screen and freezez/restart – Busy Bee Dec 4 '17 at 19:55
  • 1
    If it is the 2011 typical GPU problem, go here – LangLangC Dec 5 '17 at 21:22
  • Thanks LangLangC, I will try this fix and report back if it works – Busy Bee Dec 6 '17 at 11:24
6

Unfortunately it is almost certainly the discrete GPU on the main logic board that is failing here, not some kind of OS issue. This symptom is the most common way this issue presents in the 2011 models, especially considering the fact that your machine isn't able to boot to recovery, but does not display any boot error messages (like the ? folder or prohibitory symbol).

The 2011 MacBook Pros had a repair extension program from Apple for this issue free of charge for a couple years. Unfortunately, it ended a while ago.

You can salvage the data in target disk mode https://support.apple.com/en-us/HT201462 if you have another mac to connect yours to. You could also just remove the hard drive and connect it to another computer with an enclosure to recover data if that's what you need from it.

I know that there are definitely repair shops that do component level repairs on the failing GPU, but it would not be free. That said, Apple no longer fixes the 2011 models at all, even if you were to pay, so an independent repair shop would be your best bet anyway if you really wanted to get this computer fixed.

  • This issue happened when I upgraded from Mac OS Lion to El Capitan. This problem also exists on legacy OS? – Busy Bee Dec 5 '17 at 10:58
  • Typically once this issue starts happening it keeps happening, but theoretically you could try and see if the reduced graphics resource demand of the older OS brings the computer back to functioning somewhat. If the recovery partition won't load it could be tricky to downgrade though; have you tried using Internet Recovery as well as the normal recovery partition? That might be able to get it back on 10.7 Lion if the computer can boot to it. Press cmd+option+r at boot. It it works, you'll see a globe, and be prompted to connect to a network. Good luck! – Jess Dec 6 '17 at 15:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .