15

This question already has an answer here:

I have the following problem since upgrading to OS X 10.13.1 High Sierra on MBP 2017. A generic icon is shown for nearly all my apps. See the image below. Does anyone know how to fix this and get the applications icons back?

desktop

marked as duplicate by IconDaemon, Allan, Scot, dwightk, Monomeeth Apr 24 '18 at 22:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    seems to be epidemic... apple.stackexchange.com/questions/307773/… – Tetsujin Dec 4 '17 at 13:48
  • Booting in safe mode solves this. I wrote an more detailed answer on this duplicate questions: apple.stackexchange.com/a/308674/35889 – codingFriend1 Dec 11 '17 at 14:54
  • Just in response to "Marked as duplicate" and being very pedantic about it ;) , I think I asked the question first (on Dec 4th versus Dec 5th) so therefore the other question is the duplicate!!!! Just my immature childish side peeking through...I'll get over it! – Leeser Apr 25 '18 at 10:37
3

Try running this shell script sudo find /private/var/folders/ -name com.apple.dock.iconcache -exec rm {} \;

  • if I can find the Terminal icon ;) – Leeser Dec 4 '17 at 13:52
  • tried it but no joy – Leeser Dec 4 '17 at 13:54
  • 1
    You'd probably need to reboot afterwards. – Tetsujin Dec 4 '17 at 16:19
  • Actually it worked for local login but it still is an issue for my network login (ie to my company network). I’ll check if rebooting works and accept answer if it works but we’re half way there! I’ll get back to you in this... – Leeser Dec 4 '17 at 18:26
  • I tried it it in both local login and domain login, but it only worked for my local login, generic icons still exist in my company (domain) login. – Leeser Dec 5 '17 at 11:51
1
  1. Recursively descend the directory tree for /private/var/folders/ path and remove any file named com.apple.dock.iconcache:

    sudo find /private/var/folders/ -name com.apple.dock.iconcache -exec rm {} \;
    
  2. Recursively descend the directory tree for /private/var/folders/ path and remove any file named com.apple.iconservices:

    sudo find /private/var/folders/ -name com.apple.iconservices -exec rm -rf {} \;
    
  3. Kill the dock process:

    killall Dock
    
  • 1
    Heh, this made even more icons disappear for me. I suppose it was bound to happen, the next time I restarted. – Bluu Apr 24 '18 at 17:15
  • 2
    Recent OS X's, e.g. High Sierra, have System Integrity Protection turned on by default; these commands, even with sudo, do NOT remove the wanted files/directories. You have to turn off SIP before; the easy way is to boot in recovery mode, start the Terminal, type these commands (of course "killall Dock" is not needed) and reboot in normal mode. That worked for me. – Maurizio Loreti May 21 '18 at 10:22
  • I also added touch Applications/* and find Applications -name Info.plist -exec touch {} \; before rebooting. – Maurizio Loreti May 21 '18 at 10:30
0

Running Disk Repair out of Recovery Mode resolved this issue for me. Reboot while holding Command-R. Select Disk Repair from the menu. Select and Unmount Macintosh HD (if necessary). Select First Aid and run it. Restart from the Apple Menu.

Not the answer you're looking for? Browse other questions tagged or ask your own question.