22

How can I get rid of this message?

Message

I've tried clicking both: "Cancel" and "Run Diagnostics" buttons. I've also tried to turn off and back on the Wi-fi. I don't want to restart my mac as there are some important processes running.

I'm using a MacBook Pro (Retina) - macOS High Sierra 10.13.1

  • 4
    To clarify, clicking both "Cancel" and "Run Diagnostics" do nothing? – Jake3231 Dec 2 '17 at 20:54
  • @Jake3231 Indeed, nothing happens when I click either of them. Perhaps I could close the process from Activity Monitor but I kinda don't know how the process behind that windows is called ... – Cajuu' Dec 2 '17 at 21:00
  • I thought about the same thing, but I'm not sure what that process would be called either. If someone knows the correct process, that would be good. – Jake3231 Dec 2 '17 at 21:01
  • 1
    Have you tried turning WiFi off, and turning bluetooth off both on the mac and the ios device? – John Keates Dec 3 '17 at 1:41
  • @Cajuu', How did you manage to get that to hang? – Pacerier May 24 '18 at 18:01
30
  1. Go to Spotlight (magnifying glass in top corner) / Finder > Activity Monitor
  2. Search for SystemUIServer in CPU tab using the search bar located at top right corner
  3. Force quit it
  • 3
    You can also try killall SystemUIServer in Terminal. – usandfriends Apr 10 '18 at 16:13
9

try connecting after removing any USB device connected. It worked for me.

1

Go to System Preferences > Network > Advanced...

Select the Wi-Fi tab and you will see the list of Preferred Networks. Select the offending Wi-Fi network from the list, and click the minus button to remove it.

Now, when you click Cancel on that pop-up it shouldn't reappear.

  • Doesn't look like it works. The problem still persists – Cajuu' Dec 2 '17 at 21:09
  • 1
    This might be a little overkill, but ... Go to System Preferences > Network. Find that network in the list and then uncheck "Automatically join this network". Then, turn off your Wi-Fi. Next, go to Advanced... uncheck "Remember networks this computer has joined", and then select that network and click the minus button. Then, turn on your Wi-Fi again. – Paul Brady Dec 2 '17 at 21:57
1

I followed many tips provided thru various Apple / Mac blogs. I did all of the obvious and logical tips, router, turn-off, turn-on WiFi and my MacBook Air wouldn't connect to my wireless network, or via a Bluetooth hotspot from my phone. It would connect on Bluetooth, even sending a pairing request only to disconnect. I could not load my Network name when choosing a network

So, I connected my iPhone (Did have an active connection to my wireless network) via USB as an option in my Network on the Mac. Then went to: System Preferences > Network. Under location, I went to Edit Location, created a location named "Untitled". Instead of Automatic, I chose "Untitled." I instantly received a password request for my network. I'm now connected and Location has defaulted to Automatic.Removed the iPhone connection and I'm up and running. It wasn't pretty, but it worked.

  • Or my other favorite: connect via phone to the wifi, then connect via bluetooth to the phone. Hacky but sometimes works :) – rogerdpack Aug 9 '18 at 15:22

You must log in to answer this question.

protected by Community Feb 15 '18 at 17:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .