2

My backups stopped functioning. The error message says problems were encountered when attempt to create the folder for the backup. I looked at a list of folders and files on the backup drive and discovered a "package" from a few days ago with an inProgess extention. I tried to drag it to Trash without luck. Then, reading a suggestion (by @grgarside) to another user with - seemingly - the same issue, I went to Terminal and executed the suggested tmutil listbackups command, but the inProgress package did not appear in the resulting list (perhaps because it's a package rather than a file?)

Despite its path not being listed, I continued to follow the suggestions of @grgarside and executed the sudo tmutil delete /path/to/backup.inProgress command (replacing "path/to" with the path shown on my backup drive), but the result was this: No such file or directory (error 2)

Any suggestions? Please note that I'm a total novice. I had never heard of sudo nor tmutil until reading this thread.

  • 1
    The TL;DR is connect another external disk and get one good backup there. You'll know if your Mac has issues or it just needs to clean up the interrupted backup. inProgress is always an interrupted backup so you need to leave more time to finish that interruption than if you start a new backup. – bmike Dec 2 '17 at 13:27
1

Don't remove that is my advice. Apple protects the Time Machine space from anyone making changes so you need to break those locks first, then you need to unlink every single file in that directory and then delete them.

The system is designed to reclaim that folder the next time a backup starts, so you aren't saving yourself any time and just doing what the system will do but slower.

I would make a decision - do you need the backups on that drive. If so, restart the Mac and then let it take a day or several to get the next backup set.

If not - set aside that drive and connect a new destination if you need a quick backup. Time Machine can handle multiple destinations so you can get your next backup done, then let it chew on fixing the interrupted one.

Or - wipe that drive using Disk Utility / remove all backups of that machine using the tmutil delete to remove the machine backup and not just one interval.

Since you're still learning of sudo - please don't use it unless you know you have a good backup and that backup isn't connected to the Mac when you run sudo and you have time to do a full erase of the OS and then full restore from your backup.

Once you're set with a good backup - here's the tutorial on sudo and sudo tmutil delete

How can I manually delete old backups to free space for Time Machine?

  • Thanks for all the suggestions @bmike. I'll start with the reboot and see what happens (I tried this earlier, but circumstances may not have been what they are now, and I definitely was not taking the time to observe what was happening at the time, so perhaps - even if it doesn't fix the problem - it will give me more info to help in tracking the problem). – pkazee Dec 3 '17 at 14:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .