2

I'm trying to follow this tutorial on how to setup an ipv6 wi-fi connection, so I can test my app:

http://www.brianjcoleman.com/tutorial-how-to-test-your-app-for-ipv6-compatibility/

If I don't tick the "Created NAT64 Network", it works fine (and I can connect and use the wi-fi connection from my iPad). However, as soon as I tick that box I don't get anything (says "No Internet Connection" when trying to access from the iPad)

Setting it up with this works fine, but its on an ipv4 address:

enter image description here

Enabling NAT64 works, and shows the connection on the iPad, BUT there is no connection:

enter image description here

enter image description here

Here are the software versions of my iPad:

enter image description here

The Mac is running on 10.12.1, so should be a high enough version to do this.

1

I did the same a couple of days ago to control my app for ipv6 (even if I didn’t need to do so), you should also switch off WiFi on you router / modem and you need to switch on the airplane mode on you iPad. Mind that in the latest version of Xcode your app must be compiled for ipv6 automatically.

  • Thanks for the reply. Wouldn't airplane mode stop wifi on the iPad though? – Andrew Newby Dec 2 '17 at 7:33
  • It switches WiFi off for the moment as a default instruction, but if you switch on WiFi you will have it with airplane mode – Kateri.Ze Dec 2 '17 at 8:50
  • @Kaleri - ah ok. I tried that, but still no joy. I've also tried disabling the wifi on the router (I'm hard-wired into the Mac anyway). I tried to update my version of XCode to the latest, but it needed the latest version of iOS, and for some reason mine won't update ( forums.developer.apple.com/thread/79129 ). I'm struggling to think of what else to try :/ – Andrew Newby Dec 2 '17 at 9:03
  • Why do you need ipv6 anyway? May you’ve done the same my mistake – Kateri.Ze Dec 2 '17 at 9:12
  • Applie replied with: We discovered one or more bugs in your app when reviewed on iPad running iOS 11.1.2 on Wi-Fi connected to an IPv6 network. - Once we launch the app, the activity indicator spins indefinitely and we are not able to enter the app. . The problem is that the ipv4 devices it works fine on, so I'm thinking it must be an ipv6 issue (thus trying to get it going) – Andrew Newby Dec 2 '17 at 9:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .