10

I have an interesting problem for quite some time now. My menubar turns all sorts of states on external monitors.

I have a 3-monitor-setup on an iMac 5K. I use two external Dell displays to the left and right of the built-in screen. On my right display, when it is inactive, the menubar turns completely transparent, except for the status icons. On my left display, everything stays normal, whether active or not. On my main display the menubar turns opaque white (including status icons) when inactive.

Here's a screenshot of the situation on the main monitor with white top bar: main monitor with white menubar

And here it is on the right-most-display (icons blurred for privacy): right monitor with transparent menubar

Several reboots and even a macOS update (it happened on 10.13.0, too) didn't fix it, neither did manually killing SystemUIServer. What can I do?

Installed tweaks affecting the menubar (no difference when disabling): Bartender, BetterTouchTool

OS: macOS High Sierra 10.3.1 (17B1003)

6 Answers 6

7

I had this same issue. Using dark mode my screen would appear with the whiteout menu bar on my macbook pro when switched to working in my 2nd monitor. It appears there was a colour profile issue in Settings>Display>Colour Tab. I changed my colour profile to a generic colour on both displays then back to my chosen profile. So far this seems to have fixed the issue.

2
  • @allan thanks for the grammar check. However in the UK, colour is correctly spelt.
    – Gus Nwanya
    Commented Apr 19, 2020 at 5:47
  • Fixed for me even on Mac OS Monterey.
    – arnobpl
    Commented Feb 1, 2023 at 21:33
2

I had this issue after changing the colour profile of my Macbook and external display from Native to sRGB. Moving back to native or another wider colour gammut profile seemed to resolve the issue for me. Glad I found this as it was really bugging me for weeks.

2

I noticed that only 2 of my 4 desktops had the white menu bar; I just deleted those desktops.

1

I was able to resolve this by going into Settings > General and toggling "Use dark menu bar and dock" off and back on.

5
  • 2
    This didn't do the trick for me. I also attempted changing the window arrangement by moving the menu from monitor to monitor. Seems to have just started and the only recent changes was some Office updates so not sure what triggered it. OSX 10.14.5. Update - I disconnected the Thunderbolt 3 cables to my LG Ultrafine(s) and reversed order. Issue went away. Might be time for a SMC/PRAM Reset.
    – Mark
    Commented Sep 11, 2019 at 16:42
  • @Mark Connecting the thunderbolt cables in reverse order worked for me, too. Thank you!
    – peteallen
    Commented Apr 13, 2020 at 7:25
  • Well, it solved the problem but only temporarily. It returned in a few hours. This only seems to be a problem Dark Mode. If I switch to Light Mode, it doesn't happen.
    – peteallen
    Commented Apr 13, 2020 at 17:20
  • 1
    I was able to isolate this issue to a color profile issue. Just in case anyone else has this not stick between screwing around with cables. Settings-> Displays, color tab.
    – Mark
    Commented Apr 13, 2020 at 18:33
  • 1
    @Mark The colour profiles fix worked for me (without changing anything with cables). Perhaps post it as an answer to give it better visibility.
    – lukiffer
    Commented May 7, 2020 at 18:41
1

I believe the issue is surrounding the color profile utilized by OS X. I (for example) use Flux and right now I have 2 LG Ultrafine 22" plugged in and I was getting this white bar. I ordered new cables, I reversed them I went thru a few trials and errors. It kept coming back!

I then turned to the color profile.
System Preferences -> Displays -> Color

I figured this out due to having a Samsung CF791 Ultrawide too and its color setting was horrible. Default it was purple instead of blue and I had to switch it to sRGB IEC61966-2.1. At that point I saw the white menu bar wasn't coming back.

So try out changing your color profile. I still periodically will see a white menu bar on boot on one monitor but when it click it it goes away and doesn't come back.

1

I found that the only way to fix this is to turn Dark Mode off in the general menu under system preferences.

But I like Dark Mode sooo....

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .