I'm having troubles with Spotlight.

  1. Command Space isn't working in the first try, but when I try it again it does work. After few minutes I need to do it twice again for it to pop.
  2. I don't see app result anymore. I tried to add it to the privacy section in the spotlight setting, than remove it so it will be re-indexed. It didn't work.

Somehow I think they tied together. I have the latest OS (macOS High Sierra)

Appreciate the help.

Since I got an answer for the first one, I'll post here the solution for the second one. Just add the whole computer (ShiftCommandC) to the privacy in the spotlight settings - then remove it.

6 Answers 6


i saw this on a user's machine lately. it was acting very strangely with a couple command keys.

the solution here was to go to keyboard preference pane and clear out all shortcuts and restore defaults for each section. it seems an app this user installed was grabbing the key-combo for its own purposes, and once removing the customizing it worked well.

it might be this simple in your case.

  • It may have solved the first one. Thanks! Still couldn't find solution for the second one. Dec 2, 2017 at 22:04
  • as far as part 2" . you don't see app results meaning you see matches on the hard drive for files, but not for applications on there? there is a checkbox in spotlight preference pane for show/don't show applications in search results . Dec 21, 2017 at 0:36

Per this blog post, if you are connected to an external monitor(s) changing the desktop resolution to something else and back worked for me. Spotlight was working the whole time just off the screensomewhere:


  • It would be best for you to, at least, summarize what you are linking to (more than you have) so that if the page vanishes we still have a usable answer Mar 16, 2020 at 13:26
  • This was it for me! I couldn't figure out how to change the resolution, so I went from mirrored display to not-mirrored (Cmd-fn-dimmer) and got my spotlight back. Then I went back to mirrored and it was there again.
    – joecullin
    Apr 2, 2020 at 12:49
  • This worked for me also, i just changed the screen rotation, and the changed it back and it started working again. May 20, 2020 at 15:03
  • I just clicked on external monitor and upvoted this answer. It started working for me xD
    – Arun Gowda
    Jun 19, 2021 at 8:56

Try this:

Step 1:

Open System Preferences/Keyboard and select Keyboard Shortcuts

Click Spotlight on the left. Make sure the shortcuts are correct. If not, click: Restore Defaults.

Step 2:

How to reset NVRAM or PRAM on Mac:

Apple Support: https://support.apple.com/ht204063


YouTube tutorial: https://www.youtube.com/watch?v=MPzu7n_q6ag

Note: For me it solved the problem. 🙏


Its not Cmd ⌘+ Space at the same time. Press and hold Cmd ⌘ and then press Space. It should bring you the spotlight


After reading @neuralstatic's answer I quit Karabiner-Elements and it fixed the problem.

Then I relaunched it and Command Space still works as expected.


I had this issue on Catalina today with Adobe Ill 25. I deactivated shortcuts for both spotlight and Siri. It works now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .