2

I have a Macbook Pro 15inch Retina mid-2014. I always use an external display when not on the move.

When I plug in an external display, at home or at work, both the built-in display and the external display go blank. They are both backlit and the monitor does not go to power saving mode. I can hear notifications arriving, so it's not a freeze or panic.

This happens when using either Thunderbolt port with TB to DisplayPort cable. My displays are a 1440p HP Omen and a 4k AOC. Happens on both.

Unplugging display leaves built-in display blank, so a force reboot is required.

I am going to check if HDMI works better, but would rather the MacBook work as expected.

Edit Displays work as expected after a fresh reboot (or a force-reboot).

  • How are you plugging them in? Which port on the Mac to which port on the monitor(s) via what cable and adapter? – Allan Nov 30 '17 at 16:22
  • "This happens when using either Thunderbolt port with TB to DisplayPort cable." – Brendonwbrown Nov 30 '17 at 16:23
  • So, you're going from DisplayPort to DisplayPort. Have you tried changing out your cable? – Allan Nov 30 '17 at 16:25
  • Thunderbolt to DisplayPort, yes, which is mini-DP, correct? This happens on two different displays with two different cables. – Brendonwbrown Nov 30 '17 at 16:27
  • mDP is just the connector, but yes. Try having the monitors off when you plug them in, then turn on. Also, put your Mac to sleep, connect, then wake. See if that has any effect. – Allan Nov 30 '17 at 16:28

You must log in to answer this question.

Browse other questions tagged .