4

I've got a mid-2012 15" MacBook Pro Retina (MacBook10,1 - i7-361QM - 8GB RAM) running Sierra 10.12.6 (16G1036) that can take, literally, several hours to boot. I am not able to boot into recovery or verbose (I think I gave up holding the command-r combo after 10 minutes when my hand started cramping), or diagnostics. I will note that it is operating as usual once it does boot.

Here are some of the symptoms I've observed:

  • with AC power connected, select "reboot" (normal situation)
    • shutdown initiates, screen goes black
    • startup chimes
    • ... then ... nothing ... sometimes the keyboard lights up, sometimes not, sometimes it lights up when I press a key or trackpad
    • ... wait ... wait ... wait some more ...
    • next day it's finally ready to use
  • without AC power connected (this has happened once)
    • same as above, except after sitting all day with a black screen and no apparent activity ...
    • connect AC power, immediately get startup chimes (I haven't touched the keyboard or trackpad) and normal startup (progress bar and everything) occurs within a minute or two
  • with AC power connected, start reboot
    • next morning still not started, unplug and take to work
    • open bag at work to discover things are very warm
    • open lid, still nothing ...
    • hold power down for 10s+, press power again, repeat several times ...
    • get startled when the login screen appears suddenly only 1 minute after attempting power on

Ran EtreCheck (summary, can make full report available if it will help):

  • SSD SM256E disk0, Trim: Yes
    • disk0s1: FAT32 not mounted, EFI, 210MB
    • disk0s2: CoreStorage, not mounted, 250.14GB
    • disk0s3: Journaled HFS+, not mounted, Recovery, 650MB
  • Vitual Disks
    • disk1, Journaled HFS+, 246.77GB, 20.53 GB free
  • Kernel Extensions
    • org.virtualbox.kext.VBoxDrv, *.VBoxNetAdp, VBoxNetFlt, VBoxUSB all 5.1.22
    • com.intel.kext.intelhaxm 6.0.5

The last diagnostic event EtreCheck reports is a Kernel Panic several days ago, and, IIRC, I was running the Unity editor, VS Code and possibly playing with Metal in Unity, so that's not completely unexpected. EtreCheck hasn't flagged anything as a problem. I've been running Virtual Box since long before the problem started, and I didn't upgrade it around the time the problem started. The Intel HAXM might have been installed or upgraded around the time I started having problems, but I'm only about 20% confident in that. I'm pretty sure I had the same issues with it removed.

I don't see anything obvious in the logs, but there are also a lot of log entries and I'm not entirely sure what to look for.

My battery is reporting "Service Battery" (cycle count = 895) and it definitely doesn't last as long as it used to (probably 3-6 hours at best).

I've done SMC reset, and NVRAM reset. Disk Utility First Aid reports that the volume bitmap needs "minor repair for orphaned blocks" and an invalid volume block free count and that I need to run First Aid from Recovery, which, as I've previously mentioned, I can't get into.

Any suggestions on what to look for in the logs, or other things to try?

UPDATE: Tried booting from a bootable USB created from High Sierra installer (that was already downloaded). Set startup disk from System Prefs, and that resulted in the same black screen/no boot. Held power down to force off, then held option to get disk selector, but only got the internal drive showing (the USB activity LED did light up during the startup). I selected that and got the usual progress bar then the login screen, but after logging in everything froze and the screen went black again. That's something new.

UPDATE 2: And now Startup Manager won't load anymore.

  • Have you tried to boot the computer from an OS on an external drive, say a macOS installer on a USB stick? – David Dec 1 '17 at 3:48
  • @David Yes, see update. I'm thinking at this point it may not be the disk that's the issue, but I'd really expect there'd be something in the logs if it's a hardware fault. – Colin Young Dec 1 '17 at 14:08
  • 1
    I don't have anything else to suggest, Colin. I think it's a hardware fault. – David Dec 1 '17 at 16:04
  • Disconnect/remove the SSD, remove a stick of RAM and try to boot from the USB installer. If it fails, swap memory (same slot). Test again with the other slot (try both sticks in each slot). Report back if there was any/no change. – Allan Dec 1 '17 at 16:28
  • Macbook Pro Retina mid-2012. RAM is soldered to board... If I can find a pentalobe driver this weekend I'll try disconnecting the SSD. Otherwise I might have to take it in to the Apple store and see if they have any luck with it – Colin Young Dec 1 '17 at 16:37
1

It appears it was a hardware issue... I hope. Machine is currently with Apple having the logic board replaced. I recently discovered that the discrete GPU was not showing up under System Report, nor could gfxCardStatus detect or force it to be used. It seems my machine was one of the "very few" impacted by the nVidia chipset issue affecting machines from about 2011-2013, and apparently OS X is resilient enough that it just carries on in the face of soldered-on hardware suddenly disappearing, and doesn't consider that something worthy of bothering the user with.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .