3

Two days ago I noticed that my iPhone 7 (iOS 11.2 Beta 4) switched to another (foreign) carrier. This hasn't happened in a long time but since I live near a border I thought it plausible and just tried to go to the settings to change it manually.

That's where I discovered two things:

  1. My usual carrier is not appearing on the list, but the foreign one is appearing twice.
  2. Even if I try to change to another carrier, the name (top left) doesn't change.

Now since that time I used my iPhone in other places and there is no change at all, the carrier name doesn't change.

I switched back to automatic selection, and noticed that it seems like the only thing wrong is the displayed name of the carrier. That is because I have roaming off and I was still getting 4G. Yesterday I used 4G like usual and on my carrier's website I could verify that this was counted as normal data usage and not roaming.

I have of course tried to restart the device but it didn't change anything. Since then I've installed Beta 5 but the problem persists.

Would anyone have an idea of what I could do? I thought of contacting my carrier but I think this is mostly a software problem.

  • Have you attempted to perform a hard reset? – Jake3231 Nov 30 '17 at 14:02
  • @Jake3231 I only reset all network settings before your comment and it didn't help. Lazy me wanted to avoid the hard reset, but I just did it and it solved the problem. Still a very strange issue. Thanks. – Oliver Nov 30 '17 at 14:54
  • I have the same exact problem and I tried to reset the network settings sadly nothing changed, I even tried another sim card and still have the carrier name didn’t changed. I have an Iphone 7 with IOS 11.2.5 – Mohammed Feb 17 '18 at 13:40
  • @Mohammed Have you tried a full/hard reset of the phone, and not only of the network settings? That is the only thing that worked for me. Don't forget to do a backup first. – Oliver Feb 18 '18 at 8:45
  • @Oliver Please close the question! :) – ankiiiiiii Jul 5 at 8:48
0

A hard reset (Settings -> General -> Reset -> Erase All Contents and Settings) solved the issue. I made a backup before and used it to restore my phone after the hard reset, which did no recreate the carrier issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .