1

So, I've been having an issue on and off for a year or two where my macbook airs magsafe charger wouldn't actually charge my device, and I'd have to reset the SMC 10+ times to get it to recognize my charger.

I've recently gotten access to a second macbook (pro) so I was curious if that charger would work for my macbook air. Lo and behold, it works immediately after plugging it in the first time. So, the other macbook charger works for both that macbook and mine. My charger works for the other macbook, but in mine it takes a bunch of resetting to get it to work.

What could be causing this weirdness?

Not sure if it would help, but here's a pic of my magsafe port (there is no removable debris, it just appears to be discolored and scratched a bit):

enter image description here

  • Port looks normal. – JMY1000 Nov 29 '17 at 17:51
0

I would suggest swapping the chargers and avoiding the problem.

The original charger may not have been the correct rating - had this before where they charge but so slowly or not at all.

Macs and chargers do check what they are connected to so smaller chargers don't try to charge the larger batteries as the chargers have different ratings 60W, 85W etc...

  • Unfortunately this isn't an option, as the other macbook is a loaner of sorts. The original one worked for about a year just fine, but after that it started to go downhill. – Seiyria Nov 29 '17 at 17:01
  • Perhaps the original has developed an intermittent fault and needs replacing.. I bought a new one for mine: original apple : expensive but worked straight out of the box with no concerns... – Solar Mike Nov 29 '17 at 17:07
  • Thanks, I was hoping to not have to buy one but it looks like that might be the solution here. I'll accept your answer. – Seiyria Nov 29 '17 at 18:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .