1

After upgrading to High Sierra (I think) I've started receiving the following message almost every time I start up Terminal:

You have new mail in /var/mail/MyUsername

I had some problems upgrading to High Sierra so I strongly suspect this started after the upgrade, but cannot be absolutely certain.

When I enter the $ mail command and read the messages (which can amount to hundreds at one go) this is what is written:

Message 1:
From MyUsername@Users-MacBook-Pro.local  Tue Nov 28 21:37:04 2017
X-Original-To: MyUsername
Delivered-To: MyUsername@Users-MacBook-Pro.local
From: MyUsername@Users-MacBook-Pro.local (Cron Daemon)
To: MyUsername@Users-MacBook-Pro.local
Subject: Cron <MyUsername@Users-MacBook-Pro> /Users/MyUsername/Library/symmetrical.xm/symmetrical.xm cr
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=MyUsername>
X-Cron-Env: <USER=MyUsername>
X-Cron-Env: <HOME=/Users/MyUsername>
Date: Tue, 28 Nov 2017 21:37:01 +0800 (+08)

/bin/sh: /Users/MyUsername/Library/symmetrical.xm/symmetrical.xm: No such file or directory

Also, when I run $ crontab -e, this is what is returned:

37 * * * * /Users/MyUsername/Library/symmetrical.xm/symmetrical.xm cr
~                                                                                                                              
~                                                                                                                             
"/tmp/crontab.SsevmMDt1o" 1L, 72C

I am trying to figure out why the Cron Daemon is sending me these error messages. To clarify, I would not like to suppress mail from cron altogether; so, I don't want to

  • Delete the MyUsername file at /var/mail/, OR
  • Change the MAILTO variable in /etc/crontab to MAILTO="" (as suggested in this link)

Instead, I'd be really grateful it if someone could help me understand

  • How/why this started happening
  • What I can do to stop it from happening again (or if I should stop it from happening at all)
  • Which app/script requires the missing file/directory called symmetrical.xm and why

Any other additional information to add to the points listed above would also be greatly appreciated.

Thank you!


macOS High Sierra v10.13.1 (17B48)

  • What is the command in cron supposed to do - what did it output when you ran it from the cimmand line? – Mark Nov 28 '17 at 18:52
  • 1
    Instead of suppressing mail from cron it might be better to fix the reason cron is sending you mail in the first case: /Users/MyUsername/Library/symmetrical.xm/symmetrical.xm seems to be missing – nohillside Nov 28 '17 at 19:13
  • @Mark Do you mean when I run $ cron? I get this: cron: can't open or create /var/run/cron.pid: Permission denied – sabriele Nov 30 '17 at 19:43
  • @patrix Yes – I was wondering if someone could help explain which script requires the file because when I tried Googling "symmetrical.xm" no relevant results were returned. (I'm definitely not trying to suppress all mail from cron, only the ones that are related to this "symmetrical.xm" problem; sorry I didn't make that clearer in my original post.) – sabriele Nov 30 '17 at 19:50
  • No what happens when you run the command in a shell not via cron? – Mark Dec 1 '17 at 3:14
1
  • open Terminal
  • run ls -l /Users/MyUsername/Library/symmetrical.xm/symmetrical.xm
  • If you get an error of any kind (directory or file not found) run crontab -r to remove your crontab.
  • Thank you, this helped - the messages seem to have stopped. Still don't really get what was going on though! – sabriele Dec 11 '17 at 18:57
  • @sabriele You probably installed some software in the past which created the symmetrical.xm library as well as the cron job to regularly run the command. The software seems to be gone, but the cron job remained, trying to execute a non-existing file. – nohillside Dec 11 '17 at 19:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .