I've noticed that recently, maybe after some sort application or OS update, calendar notifications have been functioning normally in notification center BUT have also caused the calendar application (Calendar.app) to be brought to the foreground. It has no relation to what i'm currently working on or what application i'm using - it even does this while i'm typing, if a new calendar update comes in.

This is SUPER annoying as it completely distracts from whatever i'm currently doing.

1 Answer 1


So as it happens, I had recently turned on a feature in macOS Mail (mail.app) called "Add invitations to Calendar automatically". Disabling this feature immediately fixed this issue and does not prevent Calendar from receiving/notifying/displaying calendar invites. In honesty, aside from removing this really annoying side-effect it doesn't seem to have any downsides for my usage of Mail/Calendar.

Fix: Mail > Preferences > General > Disable "Add invitations to Calendar automatically"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .