0

This question already has an answer here:

macOS is not permitting me to change the file permissions of any file! whenever I try to add the admin which is me, finder gives me this error:

you don't have necessary permission - operation not permitted

In spite of the fact that I am the sole user

I have tried chmod, again same error - operation not permitted

The permissions are as follows!

enter image description here

Screenshot of the operation not permitted error I getting

enter image description here

marked as duplicate by nohillside macos Nov 28 '17 at 12:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Which file/folder are you trying to change permissions for? – nohillside Nov 28 '17 at 11:35
  • @patrix System Files! – Sayan Nov 28 '17 at 11:38
  • The first screenshot shows your home folder, the second Terminal.app, why do you think they are related? Also, macOS-installed files are protected by SIP and can‘t be changed by any user. – nohillside Nov 28 '17 at 12:03
  • @patrix I attached the first screenshot cause terminal falls under the home folder and I might be wrong but don't you think that changing permissions of the home folder changes the permission of everything inside it? – Sayan Nov 28 '17 at 12:11
  • @patrix I know about SIP and I have posted this question after disablling it, but still I get this error! – Sayan Nov 28 '17 at 12:27

Browse other questions tagged .