I have installed Slack App on my Mac OS and it works all fine. However, I do not see that application in Applications folder. I am very new to Mac and may be I am missing something but to my knowledge, IF App is installed on the machine, then it has to be in Applications folder.

Is there any reason under which it can not be in the Applications folder?

  • Your question came up for me while I was doing a search for a similar sounding problem. Question for you though, when you say that you don't see that application in the folder, what are you using to view the folder? Reason I ask, is because ls for example doesn't show what appears to be Apple's more recent "firmlinks" mechanism. Meanwhile Finder appears to show the linked application folders but not that they are brought in through Apple's firmlinks. Not sure that's the problem for you but it's why I'm asking. Jul 31, 2022 at 18:28

4 Answers 4


An app can be in any directory. It is suggested to move them to the Application folder so they are easy to find.

When you downloaded Slack it probably went to your download folder. Did you copy it from there to Applications? If so follow directions below. If not, it could still be in your download folder.

There are 2 Application folders. One is under your home directory and the other is at the root level. Slack should in the Application folder at the root level. From a finder window you can right click on the directory name at the top of the finder window. Click on Macintosh HD and that will display contents of the root directory. You should find the Applications listed there.

From the terminal, cd to the root level and do an ls to see the other directories (folders).

  • i just mis-typed. Sorry. I downloaded Skim tonight and it was on my mind. i'll correct
    – Natsfan
    Nov 28, 2017 at 2:26

With any running application that shows in the Dock, you can press the command key and click the application's Dock Tile to have a Finder window open at its installed location, highlighting the app.

If you have Finder's Path Bar showing, (at the bottom of the Finder window), then you can see its path in relation to the volume it's installed on, which it typically the Macintosh HD in the /Applications folder.

Without Finder's Path Bar showing you can right-click (control click) on the folder name at the top center of the Finder window to show its path.

  • Thanks so much. I tried literally everything on the internet and almost gave up, before I saw your post. Thanks once again, really appreciate it. Aug 4, 2018 at 15:57

This is not an “answer” per se, so much as an affirmation that I do not think you are hallicinating.

Today, one of my coworkers installed a copy of our company’s software on his Mac.

(I’m not going to identify the software here because that’s not the important detail. People have reported the same problem with Slack and JAMF, among others, so it seems to be some kind of caching thing with Finder itself, and not a bug with any of these particular examples.)

Salient details:

  • The software was installed via a .pkg installer, which wrote the files to the /Applications folder.
  • On opening /Applications in Finder, the software was not displayed; sorting the programs alphabetically, it definitely was not shown on the list where it should have been.
  • If you ran a ls -la /Applications in Terminal, the software was displayed.
  • If you ran a Spotlight search for the software, it would show up & launch, and it would run normally from there.
  • After a reboot, then the software became visible in Finder’s view of the /Applications folder.

A web search for this problem has turned up a handful of hits (Apple Discussions, JAMF Nation), including this post, but none have been very helpful — with lots of people making vaguely accusatory “are you sure you looked in the Applications folder?” type questions and so on.

In this case, we are very sure indeed that we are looking in the right folder — we have a screen recording of the problem as it was happening.

So that’s my suggestion, such as it is — I’m not clear why this happens, but if you see this behavior, try:

  1. Relauncing Finder. (Minimal disruption, might work.)
  2. Log out the macOS user account session, then log back in. (More disruptive.)
  3. Reboot. (Most disruptive, but also most likely to succeed.)
  • Perhaps the installer hid the app.
    – lhf
    Oct 1, 2020 at 0:18
  • 1
    The installer did not hide the app. My company wrote the software and packaged it in the installer, and we did not do that. More to the point, if chflags or equivalent had set a “hidden” attribute, that would have persisted across reboots. But that wasn’t what was observed here: a reboot got Finder to display the software normally. No, this seems to be some kind of intermittent Finder caching glitch. Oct 2, 2020 at 2:13
  • This has happed to me multiple times recently. I was pulling my hair out trying to understand what was going on. I could not see app in Finder but could via ls -la.. I skipped to 3rd suggestion of a reboot and that fixed it... Seems like quite the silly bug; hiding files is very un cool.
    – Basil
    Apr 5, 2022 at 4:53

I appreciate all the good detail in the answers above. Unfortunately, none of them worked for me and even though I started using the app after installation after I closed it there was no sign of it in Finder or in the Terminal list.

I still had the .dmg that had the installer package. Clicking that reopened the installer window with an image of the Applications folder and of the app I thought I had installed. I dragged the app image over to the Applications folder in that same window and the app loaded onto my list of apps in the Finder Applications folder.

Initially, I just double-clicked on the app image in the installer window and it led me through some prompts that appeared to install the app properly. Apparently, it wanted this drag-and-drop step because everything is fine now and the app is showing up in the Finder.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .