2

I've received sudo rm -rf on my machine (MacBook Pro 2017 13", Sierra). As it's expected, most of applications disappeared or stopped working.

I had to reinstall MacOS completely from the recovery partition, and it helped, but since then I have some strange graphic bugs in some applications. Mostly, games -- Steam and League of Legends. In Steam, I lack some elements of user interface -- please glance at the screenshot (it's supposed to show login and password input bars and some buttons). League of Legends manages to start up pre-game screens, but when the game begins it crashes with those things in logs:

LeagueofLegends[82544:636494] Error loading //System/Library/PrivateFrameworks/MobileAsset.framework/MobileAsset:  dlopen(//System/Library/PrivateFrameworks/MobileAsset.framework/MobileAsset, 265): no suitable image found.  Did find:
//System/Library/PrivateFrameworks/MobileAsset.framework/MobileAsset: mach-o, but wrong architecture
/System/Library/PrivateFrameworks/MobileAsset.framework/Versions/A/MobileAsset: mach-o, but wrong architecture
Killed: 9

Could anyone please assist me? Any assumption of what could I loose with rm -rf that causes such behaviour AND is not fixed by system reinstallation, and how to restore it, would be greatly appreciated. I even tried upgrading to High Sierra, no difference. Before the sudo rm -rf both applications worked fine.

Screenshot of Steam not working

  • Welcome to Ask Different! :) Your question focuses mainly on Steam/games, but you do mention some strange graphic bugs in some applications as well. Can you edit your question to provide more details on this? Also, have you tried to use your MBP in Safe Mode to test if any of the strange graphics behaviour goes away? – Monomeeth Nov 26 '17 at 21:07
  • I assume that you did reinstall Steam etc as well? – nohillside Nov 26 '17 at 21:14
  • @patrix yeah, a few times – Alagunto Nov 26 '17 at 21:27
  • @Monomeeth, it's really strange. I've tried safe mode, and it was blinking all along, random white horizontal stripes on animations etc. Everything lagged crucially, and -- more interesting -- when I tried to open applications folder in dock, it blinked my desktop black and didn't do thing. I've rebooted back, and my applications folder still doesn't work! It just blinks my desktop background black, dock disappears for a second and then comes back without applications folder open. Help please =( – Alagunto Nov 26 '17 at 21:35
  • @Monomeeth hah, I can't now even open my Applications folder from finder -- same thing happens – Alagunto Nov 26 '17 at 21:36
0

The reason is my case-sensitive system disk partition. Even though it's officially supported, some applications tend to forget it and hope the partition is case-insensitive.

For most applications (including Steam and League of Legends) appropriate solution is to

  1. Create new case-insensitive partition, name it somehow, e.g. CaseNoSense
  2. Transfer your application from /Applications/theapp.app to /Volumes/CaseNoSense/theapp.app
  3. Move your application support folder to this partition: mv "~/Application Support" "/Volumes/CaseNoSense/"
  4. Create symbolic link for the application support folder: ln -s "/Volumes/CaseNoSense/Application Support" "~/Application Support"
  5. [Optional] Create symbolik link for the application: ln -s "/Volumes/CaseNoSense/theapp.app" "/Applications/theapp.app"

    Now start the application, it might work as intended.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .