1

I'm running macOS Sierra on an early 2015 MacBook Air.

I've used the Mail.app to connect to Gmail, as well as several other account profiles for years. Two days ago, the Gmail connection failed (other accounts are loading normally).

When I clicked on accounts offline in the top corner, it explained that the login to Gmail had failed, and I should re-enter my password.

Here's the login screen it brought me to.

enter image description here

Then I entered my password (which I've checked several times for correctness) and got a grey screen of death.

enter image description here

This has repeated many times over the past two days, even when left alone for several minutes to resolve the grey screen.

Other attempts to re-enter the login information, for example through Mail → Accounts have led to the same result.

What can I do to resolve this?

Edit: Tried removing and re-adding the account. Now it freezes at the last step, after clicking done (shown with done pressed)

enter image description here

  • Welcome to Ask Different. If you were able to solve your original problem, create an answer for it. This way, you can mark the answer as accepted to close it out. – Allan Dec 2 '17 at 10:46
1

For anyone having the same problem, it turns out that Gmail blocks out-of-date mail clients from connecting and isn't too keen on informing users when it decides to do this. The solution was to update my mail client by upgrading to macOS High Sierra.

0

This has been happening to me ever since I updated to High Sierra. I had added 2-step verification to my Gmail accounts, but had to remove it. Hoping that resolves the issue but not holding my breath.

  • To clarify, did assign 2-step verification to your Gmail account resolve this issue? I suggest you update your answer to make it more clear as to what did or did not resolve the issue. – Jake3231 Dec 23 '17 at 15:22
0

Weird. I just updated osx, and after that my mail would not connect to gsuite whatever I tried. In the end I tried another email client (spark) and that solved it. Well, seems like a good alternative anyways.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .