2

I've got a 12-inch MacBook I would like to reinstall. Before doing so I've cleared the storage drive, reset the SMC and NVRAM. I've got a macOS High Sierra USB ready from which it successfully boots.

The issue is that after booting from the USB, partitioning the internal drive and going through the "Install macOS High Sierra", it reboots the machine (presumably to continue the installation) - the problem is the machine just starts from the same USB drive and brings me back to "macOS Utilities".

I've tried this multiple times already and no luck. Restarted the machine, cleared NVRAM once again, etc.

The main storage drive is not in "Startup disks" after it restarts, which I'm not sure if it's the expected behaviour. If I shut down the machine and unplug the USB, it gives me the "question mark folder icon" which implies there's nothing bootable on the storage drive, as if the installer was failing at correctly putting the initial files in there.

Looking into the EFI partition of the internal drive I can see there is absolutely nothing, which would explain what's happening - why doesn't the installer put anything in there though?

  • Sierra or High Sierra? I ask because your question refers to Sierra, but the tag is high-sierra. – David Anderson Nov 26 '17 at 17:51
  • @DavidAnderson High Sierra, my bad. Edited the question. – André Borie Nov 26 '17 at 17:52
  • The EFI partition is not used to boot macOS. Is your internal drive a single drive or a Fusion drive? Are you using the new Apple File System (APFS). If not, why not. What exactly did you do when you "cleared the storage drive"? – David Anderson Nov 26 '17 at 18:12
  • @DavidAnderson sorted, see my answer below. This is an internal SSD, not Fusion. Yes I was using APFS (formatted using diskutil eraseDisk APFS .... Clearing the storage drive meant booting under Linux and overwriting the entire drive (including partition table) with random data. – André Borie Nov 27 '17 at 13:01
2

Here I assume your internal drive is a single HDD or SSD. In other words, I assume you do not have a Fusion drive.

While booted to the USB installer, open a Terminal application window.

Enter the following commands to reinitialize your internal drive. Substitute the desired name for your installation volume for the name "Tommy".

diskutil  unmountdisk  disk0
gpt  destroy  /dev/disk0
gpt  create  /dev/disk0
diskutil  partitiondisk  disk0  apfs  "Tommy"  R

Exit the Terminal application and try installing macOS.

  • Already tried multiple times and didn't work, but thanks for the advice about the EFI partition not being necessary. – André Borie Nov 27 '17 at 13:03
1

This was possibly a bug in the installer not copying the files properly on a brand-new APFS-formatted drive (as the drive was completely wiped beforehand, including the partition table) - formatting the drive as HFS+ (which is not displayed in Disk Utility but can be done with the diskutil command) fixed the issue, and the partition got converted back to APFS during installation.

  • 1
    If you found the answer, then mark your answer as correct. This will help others with a similar problem. – David Anderson Nov 27 '17 at 17:20
  • @DavidAnderson yep will do just waiting for the timer to run out, SE only allows to accept your own answer after around 24 hours. Thanks! – André Borie Nov 28 '17 at 13:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .