1

I have been using my NAS named JBPersonalCloud for a while, and I always used Wi-Fi to connect to my home network.

A few days ago, I connected my Mac to my home network via both Wi-Fi and Ethernet for a couple of minutes to test the Ethernet speed. But then I dropped the wire and remained Wi-Fi only. However, since then, Finder has started to show my NAS as JBPersonalCloud-2. But there is no second JBPersonalCloud, and I am using the original connection interface (Wi-Fi).

NAS shown with <code>-2</code> suffix in Finder sidebar

I have tried to reboot the NAS, the router, and my Mac.But the -2 suffix still is there. Is there a way that I can change it back? Thanks!

1

Sorry, it looks like I made an assumption there.

The name you see in the Sidebar is the name of the device as it is advertised on the network. When you had the device connected to both wired and wireless networks, it probably saw itself on the network and automatically changed the name to avoid a duplicate.

To fix it, you will need to go into the administration panel of the NAS and change the name back to JBPersonalCloud. If it appears correct in the admin panel, then change the name to something completely different, and then change it back.

  • OMG! It worked! Really appreciate a lot! I didn’t expect it to be this easy to fix. – jackxujh Nov 28 '17 at 6:55
1

There is probably a “JBPersonalCloud” remnant in /Volumes directory. When you connect the NAS, the system sees that there is already a “JBPersonalCloud” and appends the “-2” for the newly connected NAS.

Disconnect the NAS and delete the remnant with the Finder or Terminal then reconnect the NAS.

Finder: Select “Go to folder...”, enter /Volumes and tap “Go”. This will open the Volumes folder in a window where you can delete the remnant. Simply drag it to the trash (you may need to authenticate).

Terminal: Open Terminal.app and type

cd /Volumes
ls -la

This will show you the list of drives that are currently mounted. If you see the remnant it can be deleted with...

sudo rm JBPersonalCloud

It will ask for an administrator password.

  • Thanks for the solution! Unfortunately, I couldn’t see the NAS in Volumes. What I saw was only the disks in the NAS, such as diskOnNAS1, diskOnNAS2. Hence rm JBPersonalCloud was not working since the NAS is not listed as a whole there. I think it has something to do with how Mac lists the founded devices on the local network. – jackxujh Nov 27 '17 at 20:09
  • Also, I added a screenshot of the finder sidebar to illustrate that the name taken wrong is the whole NAS. – jackxujh Nov 27 '17 at 20:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .