2

I found this app that I needed to disable from association to music and video files that it's capable of opening, and the app doesn't have an option to disassociate filetypes.

It's a media player, and after installation, it tends to become the default app for both music and video filetypes.

Is there any terminal command to dissociate the apps from any filetype it's defaulted to?

If not, any way to disable it from associating files as a default player for those filetypes?

Thanks!

2

lsregister is the command to deal with Launch Services. To unregister an app use the -u option and the path to the app bundle. lsregister is not in the PATH - you have to use the full path to the executable:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -u /Applications/MediaPlayer.app
  • You do not have to use the fully qualified pathname and can instead use a glob, e.g.: /S*/L*/F*/C*/V*/A/F*/L*/V*/A/S*/lsregister -u /Applications/MediaPlayer.app – user3439894 Nov 26 '17 at 1:54
  • Thanks! Isregister with -u, will unregister all file associations from that specific app? Would updating the app versions cause the app to register the file types again? – mk117 Nov 29 '17 at 11:54
  • I tried the executable command in the terminal, and it didn't unregister the filetypes for the app. Any alternative method? I'm trying to unregister filetypes for a .dmg installed software, and not an appstore software! – mk117 Nov 30 '17 at 19:40
0

Select a file type that you are having this problem with and right-click the file. Select 'get info' for that file. The 'get info' window has a section labeled 'open with' and you can check if that app is set to open that file type. If so select another app to open that file. Under that option is another option to save that info for all files of that type. Be sure to select that option.

If this was unclear let me know and I'll try to explain it better.

  • I know about the get info option. Although that's for specific filetypes – mk117 Nov 29 '17 at 11:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .