Today I updated my Mac from Mac OS X Mountain Lion to macOS High Sierra. After I log into my account I immediately see this message:

"routined wants to use the "Local Items" keychain"

I tried to use my Mac account’s local password, but the alert did not disappear.

What is Routine? How do I resolve this?

3 Answers 3


Did you change your password recently? Probable solution that worked for me:

  1. Go to the app "Keychain Access".

  2. From the side-bar, go to "login".

  3. Click on "Edit" menu from the menu bar and choose "Change Password for Keychain "Login"..."

  4. Enter the old password of your user account in the Current Password field. This is the password you were using before the password was reset.

  5. Enter the new password of your user account in the New Password field. This is the password you're now using to log in to your Mac. Enter the same password in the Verify field.

enter image description here

  1. Click OK, and exit the Keychain Access program.

In my experience, this would happen if you recently changed your system password. Since your login keychain relies on the password to be able to access the credentials, it keeps popping you the question.

Source: Apple

  • This answer is only applicable to an error regarding the 'login' keychain. The question specifically indicates the issue is related to the 'Local Items' (i.e. iCloud) keychain.
    – ghostly_s
    Jul 25, 2018 at 20:57
  • Thanks. This solved my vpn access problem. I too updated the password recently.
    – SyAu
    Sep 6, 2018 at 23:39

I had this problem too. This was my solution:

  • Open terminal
  • cd ~/Library/Keychains
  • ls
  • locate the file that looks something like this: 94ED610F-DD96-4ECF-A2BC-7D2F8651A464 (yours will be different)
  • rm -rf 94ED610F-DD96-4ECF-A2BC-7D2F8651A464 (whatever your file is called)
  • reboot your Mac.
  • 5
    Ok but what's that file? It would be wise to know what one is deleting before actually doing, especially since you won't be able to restore it
    – Aurelio
    Jan 23, 2018 at 20:13
  • 2
    As I understand it, that is the data for your local items keychain that is corrupt, hence the local items keychain error. It gets recreated automatically after you reboot and login again. If you don't have a file with a name structured similarly, you'll have a different problem. On this Mac, my file looks like the example, but starts with DA6AECA1-xxxx-xxxx-xxxxxxxxxx This is the same repair method as when you migrate a user to a new installation by hand and get other "local items keychain" errors. Jan 24, 2018 at 20:29
  • 1
    Thanks for the reply, i'll create a file backup just to be safe and see if deleting that solves the problem
    – Aurelio
    Jan 24, 2018 at 22:22
  • This should be accepted as the correct answer, these "local items keychain" errors are a common MacOS bug and this will resolve it. There is no reason this needs to be performed from the Terminal however, which is greatly complicating the answer for non-power users.
    – ghostly_s
    Jul 25, 2018 at 20:59

I just got this message today (I upgraded to High Sierra a couple weeks ago), and was also concerned about possible maliciousness. I'm not sure why routined needs access to the Local Items keychain, but I figured I'd document here what I've figured out so far:

  • Selecting cancel doesn't seem to have caused any problems, so I'd recommend that, rather than risking opening up your keychain unnecessarily.
  • routined seems to be involved in tracking recent location information.
    • I did just travel for the holidays, so something location based might explain why I'm only seeing it now.
  • Looking at running processes named routined and running strings on the binary didn't reveal anything malicious-looking (not a definitive examination, I know, but it's a start).

Other than that, my research was unfortunately mostly a dead end. All the links seemed to be references to the process's cache which includes tracking information, and all my google results seemed to be re-iterations (i.e. copy and pastes) from work by Sarah Edwards, who has a blog called Mac4n6.com. She has a "Contact Me" page, and I've reached out with a query for more information on this topic.

Other than that, hopefully someone more knowledgeable than myself will chime in. The only advice I can glean from other similar issues with keychain prompting users like this is the unfortunately unhelpful advice to try restarting the computer, recreating the user account, or re-installing the OS, none of which actually address the actual issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .