3

I would post this question directly on the Apple discussion site, but it appears to be having issues (if I log in, I get a redirect loop leading to browser error message).

I believe this issue could be related to the High Sierra update, as I believe I started seeing this issue sometime after updating.

When hovering over certain areas, the pointer rapidly switches between cursors and the mouse movement speed lags heavily. This happens the same whether I'm using the trackpad or a USB mouse.

Previously, I thought that the issue was isolated to a single application, WebStorm, and I thought that it was isolated to only hovering over hyperlinks, when the mouse cursor attempts to change to the hand icon. It would rapidly change between the hand and the text cursor and the mouse would get stuck there because it gets slowed and choppy while hovering over that text.

However, I recently noticed this happen in Google Chrome as well. Specifically (and consistently), when you enter a password for a website and the "key" icon shows up in the address bar, it asks if you want Google Smart Lock to save the password...when hovering over the white space next to that text in the bubble, it does the same thing, switching between the arrow and the text cursor.

I searched, but I can't find anyone else that seems to be experiencing quite the same issue. Others have reported issues with the mouse cursor, but not exactly the same problem I'm seeing.

I may try and revert back to regular Sierra, but I wanted to see if anyone else is seeing the same thing or has any idea how to fix it?

Here is a video showing the issue in WebStorm: https://imgur.com/m00slwn

And here is a video showing the issue in Chrome: https://imgur.com/gsKM0mn

The screencast doesn't capture the mouse cursor rapidly changing, especially in the Chrome video, but it is much more drastic than shown in the video.

  • I am noticing same kind of problems with my cursor. Hover is acting very weird. I started to notice this on Chrome. High Sierra version 10.13.1 (17B1003). Chrome version: 63.0.3239.84 (Official Build) (64-bit) – Henrik R Dec 9 '17 at 15:06
  • It may also not be the most obvious thing in the screencast, but the mouse lag is really the big issue here. The mouse almost gets stuck on those areas and when you move the mouse and expect it to have gone across the screen, but it's still stuck on that link text, it's REALLY annoying. – Travesty3 Dec 13 '17 at 16:16
  • I notice this behaviour in WebStorm on high sierra. Haven't seen it on other applications yet. – Rob Evans Jan 12 '18 at 16:07
2

I'm not sure if this is the same issue, but just in case it helps you or anyone many years later, this is what happened to me and how I solved it.

I use a larger than default cursor from the accessibility menus because otherwise I can never find the darned thing. On my Macbook Pro (new machine) I have been frustrated by the mouse feeling like it is wading through treacle when I move it over an area with lots of links in Chrome.

The right hand side of a Stack Overflow post would be a great example as the cursor is changing from arrow->hand->arrow over and over again as you move the cursor across the related links. Compared to moving the cursor over the empty space next to it I would have to move the physical mouse 2-3x as far on my desk.

I seem to have just solved this by changing the cursor scaling in the accessibility menu to a different (but similar, non-default) value.

From interrogating the values with

defaults read com.apple.universalaccess mouseDriverCursorSize

at the command line I have noticed that some values cause the problem and others don't. For example the default and max values of 1 and 4 do not cause a problem, and nor does 2. I did see the problem with 2.096360005605382 but its not just about being an integer as I didn't see the problem with 2.577354260089686. I have no idea what this information means. Perhaps some sort of cursor scaling performance bug with specific cursor sizes?

Anyway this may be unrelated to your issue as your pointer does look about normal size in those videos, but you could try playing with this setting.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .