I have a Mac Pro and a Windows computer. They are on the same internal network (my home network). The local IP address of this Windows computer is and its name is blender (I use this computer to run blender jobs). When I run ipconfig on this Windows computer it is confirmed that the local IP address of this computer is

I use this Blender computer only for running Blender jobs. Therefore the Deadline application is used. I have a Deadline slave on the Mac Pro and a Deadline slave on the Blender machine. The Deadline repository and database is on the Blender machine. This used to be Deadline 8 and everything worked just fine. Recently I installed a lot of software updates and also updated to Deadline 10.

And now suddenly I have this problem that the Deadline Monitor on my Mac Pro cannot access the Deadline database on the Blender machine.

An error occurred while trying to connect to the Database (Blender:27100, It is possible that the Mongo Database server is incorrectly configured, currently offline, blocked by a firewall, or experiencing network issues.

Also when I try to ping this blender machine ( using the command ping blender the terminal response is ping: cannot resolve blender: Unknown host and also ping does not work.

The C: drive of this Windows computer is shared with my Mac Pro. On my Mac Pro the blender machine is in the "Shared" list and I can see all the folders and the files of the Windows C: drive on my Mac computer.

enter image description here

As you can see the Blender machine is shared to the Mac Pro and on the Mac Pro I can see and access the Deadline folders. This is important because I use this Blender computer only for running Blender jobs.

Somehow the sharing between the Windows machine and the Mac is not working, but I don't know why.

I did run brew install mongodb (I hope I installed everything correctly) and I got this when run mongo

enter image description here

By the way, when I submit a Blender on my Blender machine Deadline executes the job without a problem and also the Monitor has no problems. So it seems that somehow I have a connection problem between my Mac and Windows machine (and it used to work fine).

I hope this helps. I am not a very technical person and I hope you can give me some detailed instructions on how to solve this problem or how to analyse this problem.

Trying to follow up with this mongodb I did run mongo 10.0.19:27100

enter image description here

I also have set the firewall OFF and then had another run

enter image description here

  • I'm not familiar with the blander app, but your networking should be pretty straightforward to get to the root of things. Focus on getting the ping and port scan to work on the known IP of the windows PC - once that's set, you can look again at the application or reach out to the vendor / support group for that app. (or ask a follow on question here showing exactly from where you got blender and what version, etc...)
    – bmike
    Nov 22, 2017 at 13:14
  • 1
    Please edit your question to fix the reporting of your network addressing scheme. Although its a minor point, you first claim the blender machine is, while later you claim it is
    – IconDaemon
    Nov 22, 2017 at 13:52

1 Answer 1


Your error is pointing you correctly to look at firewall and networking.

This should be fairly easy to narrow down with some facts:

  1. If you don't have DNS - use IP addresses for all testing - fix the Mac and PC to specific IP
  2. Ping works from Mac very reliably - you can use the network utility to ping by IP or host name.
  3. Network Utility will also be useful to port scan the PC. You should be able to tell if the windows firewall is blocking your access

My hunch since I run mongodb all the time on Mac and PC is your firewall would be likely blocking access. The only issues I never have is wrong IP, wrong port, firewall blocking, mongo configuration.

If you are comfortable on the command line - get mongodb on the Mac from https://brew.sh and then run brew install mongodb so you can connect from the command line and see explicit details on what errors happen.

$ mongo
MongoDB shell version v3.4.10
connecting to: mongodb://
2017-11-22T07:10:38.494-0600 W NETWORK  [thread1] Failed to connect to, in(checking socket for error after poll), reason: Connection refused
2017-11-22T07:10:38.501-0600 E QUERY    [thread1] Error: couldn't connect to server, connection attempt failed :
exception: connect failed

So in your case, use the command line mongo to attempt a connection to your server at

  • hi I am very happy with your answer and I tried to install and run this mongoldb. See my edited question. As you are a deadline user I really hope you can help me find the source of my problem. Deadline used to help me with Teamviewer but for some reason they have stopped that, so I am on my own now
    – Old Man
    Nov 24, 2017 at 14:06
  • please let me know what actions I should take to find out what is going on. many thanks
    – Old Man
    Nov 24, 2017 at 14:07
  • As you can see I did run this mongoldb but I cannot understand what it says
    – Old Man
    Nov 24, 2017 at 15:13
  • The mongodb part of your answer may not be particularly fortunate, because a) mongodb has to be started first (either with a custom launch daemon or with brew services start mongodb) b) mongodb is running on the Windows host, so installing mongodb on the Mac and trying to connect to it locally ( won't help much!
    – klanomath
    Nov 24, 2017 at 17:03
  • @klanomath of course the op needs to know the credentials and connect remotely. It’s looking like the “if you are familiar” portion may not be a good assumption. Not trying to write a tutorial, just post it you could get a better error message with the local mongo tools
    – bmike
    Nov 24, 2017 at 20:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .