4

I recently moved my iTunes library to my Netgear ReadyNAS NV+ (all relevant file operations on the NAS are using AFP protocol). The library had previously been on my Mac Pro, in my ~/Music directory. In iTunes Preferences > Advanced, I changed the path of the iTunes Media Folder to the Media volume on the NAS, so that it now has the path /Volumes/media/Music/iTunes Media. In iTunes, I chose File > Library > Organize Library, then chose Consolidate Files from the Organize Library dialog. This made iTunes copy all of the files from the Mac Pro's iTunes Media Folder to the iTunes Media Folder on the NAS. After that, I deleted the 60 GB of files in the Mac Pro's local iTunes Media Folder (the boot drive is an SSD, so I needed the space).

Two questions:

  1. On the Mac Pro, the setting for the location of the iTunes Media Folder has changed back from the NAS to the local folder twice now; I've had to reset it back to the NAS. Some apps have been updated, and I discovered that the updates had been downloaded to the local iTunes Media Folder. After I reset that location to the NAS and re-ran Consolidate Files, the apps were copied to the NAS. Any idea what's causing iTunes to "forget" the NAS location and revert to the local folder, and how to solve that problem?

  2. After I moved the library on the Mac Pro to the NAS, I also pointed the copy of iTunes running on my MacBook to the NAS, so that it could share the files (I can still share the files using Home Sharing from the Mac Pro, of course). It appears that the MacBook doesn't seem to simply read the state of the library from the NAS; it erroneously shows that 84 mobile apps need updating, and some TV shows that I downloaded on the Mac Pro don't appear on the MacBook. I'm OK with simply using Home Sharing on the MacBook if necessary, but I was hoping the two machines could share the same library on the NAS and would stay in sync. Can you explain the MacBook behavior? Is there a fix that would keep the iTunes libraries on the two machines in sync?

4

I can answer the second part of your question. Since you just updated the MacBook's iTunes settings to point to the NAS, it's iTunes library file still resides on the MacBook. This is a .itl file in your ~/Music/iTunes folder.

iTunes relies on this database to tell it what's in the media folder. If you add stuff to the media folder without adding it through iTunes (i.e. just dropping files in Finder, or using another copy of iTunes on another machine) then that .itl database does not get updated.

So when you add files through iTunes on your Mac Pro, it updates the .itl database on your Mac Pro, but not your MacBook, so the MB can't see those files. If you add anything through iTunes on the MB, the Mac Pro database won't have it, since the copy of iTunes that connects to that database did not process the files.

I have a similar setup to what you're doing: iTunes media on an external drive connected to my iMac, and a MacBook which I use ONLY Home Sharing on.

You might get the idea to move one .itl file to the NAS and open it in iTunes on both machines, and this will work, but you can/should never have it open in both at the same time. That .itl file is really just an SQLite database, and they don't allow simultaneous access, so I've never even attempted this.

With respect to your first question, check ~/Music/iTunes and see if there are any old library (.itl) files. It's most likely that iTunes is opening an old copy or a backup of the database. If you duplicated the database or started a new one before moving your media, this might be the cause.

Start iTunes and make sure the media folder is set correctly or make some other change in iTunes. Now go to ~/Music/iTunes and look for the .itl file that has most recently been modified. Move all the others out of the folder.

Quit iTunes and restart it while holding the Option/Alt key. This will bring up a dialog that lets you select which database to use. Select the .itl file you left alone and it will continue using that as the default library.

  • another option to Home Sharing is to just added the new files to the other library using File>Add to Library. This will update the iTunes library for that computer and either show a new asset or display that an app has been updated. You would need to do this if you were updating different iPhones on the different computers. The computer that you added the asset to the Media folder on will already know where it is. – AMR Jul 31 '15 at 14:31
1

This question was from 2011, so you may have figured out what is causing issue one by now, but here is what I have found, as I have a very similar setup to yours.

If you open iTunes when the you are not mounted to the music volume on your NAS, the tendency is for iTunes to default the iTunes Media location setting that you set in Preferences>Advanced back to the local music library.

Then, even if you are connect to the NAS at a later time but don't realize the reset of the iTunes Media location has taken place, any downloads you do, App updates, music, movies, etc., gets add to the local media folder.

If you change the iTunes Media back to the NAS, then you can go to iTunes and control + click the asset and select show in finder. Then you just drag it to the NAS location and move it there and iTunes Library should reset it's pointer to the file.

The ways that I have tried to prevent this from happening have been to set my NAS Music volume to open at startup automatically and the try and not plug my iPhone into my MBP when I am away from my home network. If you don't open iTunes while the computer is not connected to the NAS, then it will not know that it is missing and will not reset where iTunes Media is stored.

If you want to use iTunes when you are on the road, then save some of your assets to the local music folder, and then remember to reset the preferences when you get home.

1

The default library is /users/yourname/music/itunes. Just go to that folder and press Command+I. Then you can do either one of the following. You could do both but you don't have to.

  • At the top of the File Info dialog box, in the General section, check the box labeled "Locked." A lock will appear on the folder.
  • At the bottom of the File Info dialog box under Sharing and Permissions, make all three settings "read only."

After you do that, iTunes can no longer create a library in the default location. If it tries to revert, it will prompt you for the location of the library. That's annoying, but it is much, much better. You don't end up with media files scattered.

If you have files in both places, copy the files from the internal library into the external library into the corresponding folders, then Open them with iTunes to add them to the library.

This is one of those things, like duplicate files, that is not a bug, annoys the crap out of people, but doesn't cause customers to go away. So Apple will never fix it.

  • This doesn't seem to work in macOS Sierra: "The folder iTunes is on a locked disk or you do not have write permission for this folder". – Winterflags Sep 21 '16 at 11:12
  • I'm using Sierra. Try to use administrator credentials to change permissions on the folder. If that doesn't work, use Terminal. Issue the ls -la command to view a directory listing. The owner of the folder should be the same as your account short name. If it is not, issue this command "sudo chown [YourShortName] Music, then enter your password. After that you should be able to change the permissions. – Ken Collins Oct 15 '16 at 1:22
0

You can read that : http://geekmeupscotty.blogspot.fr/2015/01/music-files-in-nas-dont-mean-your.html

@Vikash: you're very right, when the lib is local, the lib can't really be shared with other devices... unless you decide to define a master computer that manages the lib locally and have it sync'd to a Nas folder. Even though, if a user of one of the other devices that connected to the NAS synced lib files, add his own music to the collection, it will overwrite the NAS lib file, but the master computer will re-overwrite it on sync.

I wonder what happens when u put your .itl file on a dropbox synced between all the users...it might be a great idea... specially since dropbox (or other sync services keep the many versions of your files).

  • You will get merge errors for the .itl file on dropbox as a program writes to it and won't see other machines changes – Mark Jan 8 '15 at 13:29
  • You're right unless the users don't use itunes at the same time... :( – metacapuche Jan 9 '15 at 10:07
  • Not just don't use but don't have it open at the same time – Mark Jan 9 '15 at 12:07
  • What happens when they do, when the itl is on the NAS? same nah ? – metacapuche Jan 19 '15 at 16:00
  • One will save over the top of the other, the chnage to the other (e.g. play count add of tracks) will be lost – Mark Jan 19 '15 at 16:02
0

Because the iTunes Library is a database that can be accessed by a single client and Apple has not shown much interest to change and improve all this you currently can only make use of the iTunes Server of your NAS, if your NAS have any. To have the iTunes Library on a remote network location is just not a good idea. It can work, but it can give problems too. And especially it you are going to invoke the Library by multiple computers with iTunes on it.

So just better activate the NAS specific iTunes Server application and let it direct to the Library with all the music folders that you first have transferred to the NAS. Then you start iTunes with the Option key pressed to make sure you are going to let it point to a local Library as well and create a new Library. Later when iTunes is started you choose your NAS in the pulldown menu in the upper left corner.

A downside of all this is that your Library is not managed by the clients, it is play-only. But all clients can use and play from the same Library at the same time.

It is needless to say that this is also not an ideal situation. Let's hope for a better solution provided by Apple including a migration of current Library database in something better that has proper network capabilities.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .