3

I would like to restart the AFP service but I'm not sure how to do it anymore. In previous versions of OS X I would run serveradmin stop afp and serveradmin start afp, but serveradmin is no longer available in High Sierra.

4
  • 2
    It’s a good time to look at smb sharing now that you’re on 10.13 and AFP began deprecation on 10.9 in 2013 - apple.com/media/us/osx/2013/docs/… (also see this post
    – bmike
    Nov 22, 2017 at 10:54
  • Right-o, I should take the hint hey haha. Thanks!
    – Matt
    Nov 22, 2017 at 12:11
  • We still use AFP in production, served from both windows and macOS. But, I’m actually shocked we still are on the old “for reasons” despite the long notice to start cutover.
    – bmike
    Nov 22, 2017 at 12:14
  • I'm setting up a Linux machine as a Time Machine backup server and Samba doesn't support that (yet) so I was going to use AFP for now. Looks like it's coming in the next Samba (4.8) release though.
    – Matt
    Nov 22, 2017 at 12:16

2 Answers 2

3

serveradmin is still available in macOS High Sierra. Server.app has to be installed though and launched at least once to start its set-up.

host:~ $user: which serveradmin
/Applications/Server.app/Contents/ServerRoot/usr/sbin/serveradmin

host:~ $user: sudo serveradmin fullstatus afp
afp:state = "STOPPED"
afp:readWriteSettingsVersion = 1
afp:logging = "NO"
afp:servicePortsRestrictionInfo = _empty_array
afp:startedTime = ""
afp:guestAccess = "NO"
afp:logPaths:errorLog = "/Library/Logs/AppleFileService/AppleFileServiceError.log"
afp:logPaths:accessLog = "/Library/Logs/AppleFileService/AppleFileServiceAccess.log"
afp:failoverState = "NIFailoverNotConfigured"
afp:servicePortsAreRestricted = "NO"
afp:setStateVersion = 2
afp:currentConnections = 0

AFP won't work with shared APFS volumes!

1
  • I see, I was hoping not to have to install Server.app. No matter, I might investigate samba for my purpose. Thanks!
    – Matt
    Nov 22, 2017 at 11:57
1

System Preferences -> Sharing would allow you to turn off all file sharing, then turn it on again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .