0

For several weeks, I haven't been able to go full-screen in any app on my laptop. I thought it was a Chrome problem with YouTube, because when I hit the full-screen button in a movie (bottom-right corner of the movie) it will expand to fill the browser window, but not the whole screen. Then to restore, hitting Escape or the exit-full-screen button doesn't get the video to reduce down again. Reloading the browser page works, though.

However, it's not just a browser problem - I recently discovered that no apps (e.g. Finder, Photos, Terminal, Console) can go full-screen by clicking on the circular green button on the left side of their window bars.

On a random cargo-cult recommendation I saw here, I trashed my ~/Library/Preferences/com.apple.finder.plist file & restarted the Finder, but no differences are observed.

When I hit the green maximize button in a Finder window, it seems to crash that window - I can no longer drag that window around & it doesn't respond to any clicks. Other Finder windows stay fine.

To try to debug, I've poked around in various system logs, but I haven't found anything that looks relevant. Maybe something to do with the WindowServer?

I'm on a MacBook Pro (Retina, 15-inch, Mid 2014), running Sierra 10.12.5.

1

Tried a couple more things, and here's what worked: kill the Dock, then get it to restart. I did this by doing killall Dock in the Terminal. It didn't restart by itself, so e.g. Cmd-Tab didn't work to switch applications, my desktop had no background, and (of course) there was no Dock.

I launched the Dock again by going into System Preferences & clicking on the Dock pane.

Why did I try killing the Dock? Because I also noticed that Exposé/Mission Control wasn't working either. Some searching led me to this question, which suggested restarting the Dock.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .