1

I have MacBook Pro late 2013 and PC with Windows 10. Also, I have two Dell U2414H monitors.

My setup looks like this:

  • MacBook Pro is connected via DisplayPort with both monitors.
  • PC is connected via HDMI with just one monitor.

Problem is with mac when I want to run OS X and Windows simultaneously. When I switch input source on one monitor to HDMI (for Windows), macbook still "thinks" it's connected to both monitors and renders screen on both and it put some pressure on GPU… I guess it's because monitor is enabled and signal is going through DP cable to mac.

Is there anything I can do? Because right now I have to manualy disable cable every time and it's annoying as I need to do this few times a day.

  • 1
    Your monitor is still sending a clock signal even though the input is switched - it's a hardware thing. Why can't you just go on the Mac and turn off the extended screen via display preferences? – Allan Nov 21 '17 at 22:11
  • Yes, I know it's hardware thing. That's why I'm asking if is there any way to resolve this on software level. Because I know how to resolve it on hardware level - just disconnect cable. How can I turn off extended screen via display preferences? In System preferences -> Monitors I do not see such option anywhere. The only solution I found out googling is to swtich to mirroring display… But that's not a real solution because second screen is still rendering and GPU is still working. – Kayne Nov 22 '17 at 8:31
  • "Why can't you just go on the Mac and turn off the extended screen via display preferences" there is no such option possible in OS X, sadly. – Kayne Dec 7 '17 at 15:28
1

So it turns out that the only solution is to use mirroring display. The signal is still sent but GPU is not overworking. MacBook doesn't heat up as with regular using two displays.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .