0

I am using a PC keyboard with a Macbook Pro, and I'm trying to get Sublime Text to behave like it does on Linux in terms of keyboard shortcuts. I copied the default keybindings file from Linux, which mostly worked, with the exception of Ctrl + C for copy.

I can't figure out why Ctrl + C doesn't work, since Ctrl + X cut, Ctrl + V paste, etc. all work. It seems like only copying is broken. I also tried going into Preferences > Keyboard > App Shortcuts, and added a shortcut for Sublime Text with ^C mapped to "Copy". Unfortunately, that didn't work either.

Does anyone know why this is happening and how I can fix it?

1

Update: I'm still not sure what the problem was, but deleting ~/Library/Application Support/Sublime Text 3 solved it. It looks like my default Sublime packages got screwed up to the point where it was somehow overriding all the user provided keymaps, among other issues. But now that I've regenerated the folder, setting keybindings works like normal.

As for why only Ctrl+C was affected and not Ctrl Z, X, or V, it's because Sublime has a default shortcut for Ctrl+C defined on Macs (cancel_build), but no shortcuts for Ctrl+Z, X, or V. Other shortcuts which clash with a predefined shortcut such as Ctrl+K were also broken.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .