4

This message keeps coming back: "Your carrier may charge for SMS Messages used to activate FaceTime"

I managed to get rid of it before but when I change the SIM card it pops up again.

It's similar to "Your carrier may charge for SMS messages used to activate iMessage", which I got rid of this time but I don't remember how.

How to quickly ensure both these messages don't pop up:

  • Your carrier may charge for SMS messages used to activate iMessage
  • Your carrier may charge for SMS Messages used to activate FaceTime

Ideally forever, but I'm ok with a quick solution that I can quickly find back here on Ask Different.

Oh and I want to keep Facetime enabled. Not sure about iMessage.

3

Source

You didn't mention the iOS version you're using so I'm assuming you're on the 11.1.2. Here's a few things to try (not in any particular order):

  1. Make sure that your date, time, and time zone are set correctly. Turn Messages off and on in Settings > Messages. Open Message, under the Message settings, a popup message will appear saying your carrier may charge for SMS messages and select “Cancel”. Message activates itself after you have clicked Cancel.

  2. Make sure that your iPhone has the latest version of iOS. In not, backup your iPhone and then simply update.

  3. Remove and reinsert the Sim card. Apple explains how you can do that.

  4. Tap Settings > Your Name (and iCloud ID). Then tap Name, Phone numbers, Email. Under Reachable At tap Edit and add your phone number.

  5. Reset network settings. Go to Settings > General > Reset > Reset Network Settings. As the action states, this will reset your network settings (e.g. your Wi-Fi passwords will be removed etc).

If you are still having this problem, contact your cell carrier (AT&T, T-Mobile etc.). You may also contact Apple support.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .