5

I have been having a bunch of email problems and want to start over. I have deleted all the IMAP accounts from Mail. What other files do I need to delete, hidden and otherwise, to make Mail (and only Mail) just like a clean install?

7

The following directories should be empty:

  • ~/Library/Mail
  • ~/Library/Mail Downloads
  • ~/Library/Application Support/Mail
  • ~/Library/Caches/Mail
  • ~/Library/Caches/com.apple.mail

The following files should be removed:

  • ~/Library/Preferences/com.apple.mail.plist*
  • ~/Library/Saved Application State/com.apple.mail.savedState
| improve this answer | |
  • Tried this, but it does not work for me to get of rid of my problem with Mail Default Reader preference selection. – user18723 Feb 14 '12 at 15:51
  • Then maybe it's better to ask a new question describing your issue. Screenshots may help as well. – nohillside Feb 14 '12 at 17:52
  • I tried this and now when I open mail after add an account it sits there doing nothing. It doesn't go get my mail from the server. – Andy Arismendi Jan 14 '15 at 18:29
  • The solution was aimed at OS X Lion, things may have changed in the meantime. If deleting the additional file listed in the other answer doesn't solve your problem, it might be better to ask a new question using the Ask Question link at the top. Please add a link/reference to this question here. – nohillside Jan 14 '15 at 18:41
  • What about com.apple.mail-shared.plist, should I remove that one too? – rraallvv Aug 3 '17 at 16:17
1

In addition to the folders mentioned by Patrix, I discovered that Apple Mail (at least the OS X 10.9 Mavericks version) is using another folder, at:

...../Library/Containers/com.apple.mail

After I had tried to do a clean restart of Mail by disabling (re-naming) all the folders that I thought that it was using (and having done a Force-Quit of the process "cfprefsd" in my username, to further reset caches), my Mail froze on trying to start up.

When I also disabled the folder in Library/Containers, the Mail application was able to start up.

| improve this answer | |
  • Which OS X version are you using? – nohillside Jan 30 '14 at 12:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .