macOS 10.12.6, Photos 2.0, running on a mid-2010 Macbook Pro.

I updated my Macbook Pro to Photos when Photos was introduced, and it has worked well for me. Two days ago, however, Photos began to misbehave by not showing pictures in the Photos Library which had been taken after August 2015. Until this occurrence, these pictures had displayed correctly. The Mac's OS is up to date. I repaired the Photos library, and restored the Photos library from a Time Machine backup, and restarted in Safe Mode. Photos continues to not display these pictures. My pictures are managed locally only; iCloud is not involved.

I have a second Mac, a Macbook Air I use for travel. For a consistent user environment, the Air runs the same software as the Macbook Pro. Photos on the Air correctly displays the entire library of photos, including those taken after mid-2015. I copied the Photos Library from the Air (~/Pictures), and replaced the Macbook Pro's Photos library with the Air's file. With the Air's library installed, the Macbook Pro's Photos continues to truncate and doesn't display pictures from after mid-2015. I repaired this Library (launch Photos while holding command and option) but Photos' misbehavior on the Macbook Pro continued. Both computers' Photos are Photos 2.0, build 3161.4.140.

What else might I try? Is there a cache to empty or a preferences file to trash?

1 Answer 1


Solved. Photos was set to read a different Photos library, not the complete one I’d copied from the Macbook Air. Launching Photos while holding the Option key brought up the “Select Library” dialog. I reset the selection to the correct complete Library, and the entire suite of pictures immediately appeared.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .