3

I just switched from iPhone 7 Plus to iPhone X. I have Apple Watch Series 3. Everything worked great until I switched to iPhone X. Now the Activity app on the phone (not the one on the watch) just gives a black screen with a spinner in the center and never does anything. Things I've tried/verified:

  • I went to iCloud > Devices and verified that the old iPhone 7 Plus is no longer tied to my account.
  • Before I shipped the iPhone 7 Plus back I erased all content and settings.
  • I've tried resetting the watch and setting it up as a brand new watch with the iPhone X.
  • Everything is turned on under Settings > Privacy > Motion and Fitness.

Running iOS 11.1.1 and watchOS 4.1. I'm stumped.

What else can I try to resolve this?

enter image description here

UPDATE: It appears the Health app on the iPhone X has the same spinning wheel that never goes away:

enter image description here enter image description here

Another thing, not sure if it matters but want to give as much info as possible. This iPhone X was restored from my iCloud backup of a iPhone 7 Plus that was part of the beta program. It was at version 11.2.(something). But I could not put backups from that version on my new iPhone X. So I had to downgrade my iPhone 7 Plus back to 11.1, then do an iCloud backup, then I was able to activate/restore my new iPhone X from that.

  • Just to clarify, is it only the Activity app you're having an issue with? What about the Health app on your iPhone X? Is it connecting to the Apple Watch (i.e. it can see it as a device under Sources and tapping on it allows you to see data)? – Monomeeth Nov 18 '17 at 1:51
  • @Monomeeth good question, I hadn't checked the Health app til now. It's not working either. I added photos of the Health app to the OP. – gfrobenius Nov 18 '17 at 13:26
  • Related: Health data keeps disappearing without reason – Stevoisiak May 18 '18 at 23:35
2

It really sounds to me like a connection issue, especially since we've established multiple apps being unable to read data from the Watch.

I would go through the process of unpairing and then restoring your Apple Watch to see if that resolves the issue. See: How to unpair and restore the Apple Watch.

If that fails you can call Apple Support as they can actually run diagnostics on your Apple Watch remotely (you will need to have your iPhone with you as well in order for them to do this). It doesn't take long to do and will help identify if there are any hardware issues.

| improve this answer | |
  • I had tried unpairing and paring multiple times with no success. But will mark this as the answer since it did involve me finally calling Apple support. They said to try backing up then restoring the phone also. First, I noticed in iCloud under devices that the iPhone 7 Plus showed back up, so I removed that from my account. Then I backed up and restored the iPhone X. Then setup the Watch as a new watch. Now the Health and Activity apps on the phone are working. – gfrobenius Nov 21 '17 at 18:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .