3

This particular problem was discussed here before @ I can connect to internet only in Safe Mode. Solutions offered there did not work for me. I have an older MacBook Pro, Mid 2009, El Capitan 10.11.6. My problem is that I can only access the internet in safe mode. This occurred last week.

It is possible that it occurred as a result of my installation of Apple Security Update 2017-4. My MBP is the only device in the house affected by this. iPads and another MBP are working fine. Problem MBP shows perfect wireless connectivity but I can’t open a web page, I have tried all the suggestions I found on this and other boards. This includes

  1. restarting DSL modem and TP Link router
  2. trying connection via Ethernet
  3. trying connection via coffee shop network
  4. deleting plist files as suggested
  5. zapping PRAM
  6. running kext utility
  7. running Etrecheck
  8. pinging router and Google
  9. running Disk Utility
  10. running wireless diagnostics
  11. turning off my Kaspersky security suite
  12. creating a second admin account for testing
  13. double checked my Network Preferences
  14. compared Activity Monitor processes in norma; and safe mode

and spent time on the phone with both my ISP and TPLink and probably some suggestions I now don’t remember. The only thing that works is starting in safe mode. Prior to this problem the MBP was showing its age, particularly the need for more RAM but it was working fine.

I freely confess that my own human error might have misconstrued any of the advice. Any suggestions gratefully received. Keith

2

In a sense you have two options:

  • Option 1 - Cut your losses and do a fresh installation of macOS, followed by restoring your data from your Time Machine (or other) backups1
  • Option 2 -Continue troubleshooting your current installation

The first option will almost certainly resolve the issue, the second option may eventually resolve the issue.

Keep in mind that if you continue troubleshooting, that this is a process of elimination and often requires patience.

I assume you already know how to freshly install macOS and restore your data from a backup, so for now I'll focus on how I would troubleshoot this further.

Since the problem is not present during Safe Mode then it's time to investigate login items, fonts, and kernel extensions.

Investigating login items, fonts, and kernel extensions

Let's start with Login Items:

  1. Startup normally
  2. Go to System Preferences > Users & Groups
  3. Select the Login Items tab
  4. Take a note of your Login Items
  5. Now remove all of them by highlighting them and clicking on the - button below
  6. Restart your computer

Now your Mac will boot up without those login items loading. Test to see if you can connect to the Internet:

  • If you can, you know one (or more) of the Login items were causing the problem. You can then add them back in one by one until you've identified the culprit. Problem solved.
  • If the problem does persist, it's either a problem with fonts you've installed yourself or with a 3rd party kernel extension. A little more info below:

Fonts:- You can remove any of the fonts you've installed yourself to see if this makes a difference.

Kernel Extensions:- You can open Terminal (found within your Utilites folder) and enter the following command:

kextstat | grep -v com.apple

The above command will list 3rd party kernel extensions (you may need to stretch the Terminal window so it's easier to read). Look for anything you don't remember installing, or something that belongs to software you've removed, or just anything that looks out of place. Remember though, this is a list of 3rd party kernel extensions and therefore any of them could be causing the problem.

If you still can't connect once you've gone through the above process, I would suggest that continuing to troubleshoot this will cause more frustration and take more time than just cutting your losses and doing a fresh installation of macOS.

1 I assume you have a backup regime in place. If not, start using Time Machine or some other backup software now!

  • I have moved to option 1 and made a clean install of the OS. And no surprises, everything works exactly as needed. Your answer made me realize I was too caught up in the mystery of the problem. Thanks! – antproof Nov 19 '17 at 2:48
  • That's great! I'm glad you resolved the issue and all is well again. :) – Monomeeth Nov 19 '17 at 4:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .