2

There's some weird linkage between my iPhone and Mac. When I go into certain apps, it brings up an icon on my Mac. I do not want this ever. How can I disable this?

3

Go to System Preferences → General and disable ‘Allow Handoff between this Mac and your iCloud devices’.

This feature is called Handoff, part of Continuity. You can read more about it in the Apple KB:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .