1

I am running: MacOS High Sierra on a 2016 TB MBP. >> App: Parallels Desktop 12. >> VM: Ubuntu Linux 16.04.

I only use the terminal of the Linux VM to communicate with robotic hardware.

When I use the terminal, I need to use generic Linux command line keyboard shortcuts.

This results in problems, to name a few:

-the cmd key shortcut cannot be disabled in the linux VM. -all kinds of shortcuts such as ctrl-A, B, C, D, etc. result in actions that are not desired when using in a Linux Terminal.

I know that I can change the settings in the Parallels VM preferences, and within the system settings of the VM. However, nowhere I can find the most annoying shortcut of all, ctrl-D, that results in the following:

result of ctrl-D shortcut when using the Linux terminal

This shortcut, when running the MacOS, does not result in this dictation-like pictogram, so it is somehow a shortcut for either Parallels or Ubuntu.

My goal is to disable as many keyboard shortcuts as possible in the Linux VM/Parallels so that all the keyboard shortcuts are available for the Linux terminal command line.

  • Parallels has a key remap pref somewhere.. on phone right now & cant remember precisely where – Tetsujin Nov 15 '17 at 14:22
  • It's in Preferences > Shortcuts. You should probably try Send System Shortcuts: Always. – SilverWolf Nov 22 '17 at 21:16

You must log in to answer this question.

Browse other questions tagged .