0

I am very much new with all of this. I installed Homebrew from the Terminal and I am now stuck on figuring out why the terminal commands from brew that installs UPX is outputting errors, albeit, they derive from the first error. I am feeling that this might be a parameter or some sort of setting error. I matched the finished installation code from the site I used to get the brew download/install code with my successfully completed report from Terminal and everything lined up to a T.

This is the code I used:

mac$ brew install upx $ upx -d /Applications/Ableton Live 9 Suite.app/Contents/MacOS/Ableton Live 9 Suite ; exit;

Error ouput:

/usr/local/Homebrew/Library/Homebrew/brew.rb (Formulary::FormulaLoader): loading /usr/local/Homebrew/Library/Taps/homebrew/homebrew-core/Formula/upx.rb

Error: No available formula with the name "$" //main error which obviously makes no sense to me, almost like an oxymoron. But again, it is probably the tidiest answer to solve and likely the easiest I will come across.

==> Searching for a previously deleted formula...
Error: No previously deleted formula found.

==> Searching for similarly named formuclae...
==> Searching local taps...
Error: No similarly named formulae found.

==> Searching taps...
==> Searching taps on GitHub...
Error: No formulae found in taps.
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.

Was I supposed to restart Terminal? Mac? before trying to install UPX? Shell//Edit/New Window//Copy Special --> Choose Homebrew before UPX?

I have never done this live (other than suggested programs to write and compile code for school), let alone on a Mac; however, I am not sure any of that is relevant in the scope of learning.

Albeit, I am not anymore familiar with the rest of the parameters than I am confident about trying to accomplish this which obviously, is not the end goal I have. I am not even sure it will work because of 3.92 beta. It is possible, if I find that it is no longer a beta but actually their 4th or most recent version, I will be able to decompress an exe file. As I understand, El Capitan and Sierra set up strange but mostly irrelevant security diagnostics.

I think I will give myself a reboot, breathe and start over.

Any guidance is greatly appreciated! Thanks :)

  • 2
    I'd like to edit your question to format the terminal input correctly, but I'm not sure what your input was exactly. can you please properly format code snippets by editing this post, and viewing the formatting help. Thank you. – Jahhein Nov 15 '17 at 17:42
  • Hi, Jahhein. Thank you for replying down below. You and vykor are very kind and well, smart! You both were major help.. I purchased Ableton almost 7ish years ago and unfortunately, while transferring jobs/offices, my car was broken into and 2 laptops, my external HD, my synth and ALL of my production was gone. I was able to rip the original file off my dads iMac but it came with issues. My best friend gave me his version of Live 9 as it was of no more use to him. I have to authorize it and Ableton has rules. I read if I compressed the exe file, it would bypass the security parameters mac set. – Tyler62515 Nov 17 '17 at 1:28
  • I've never attempted doing something like that, nor would I think it would work. Are you referring to a 'exe' as in a .exe extension file like in windows? – Jahhein Nov 17 '17 at 1:33
  • (*Apple set)[*Decompress*(not compress)]. In order to do that, Homebrew needed to install and then UPX which I guess has been in the works over the last few years. What I read, however, was only from a year ago and I think its become 3.94 now, no more beta testing. Anyways, if I can decompress the exe file and it still will not work, then I will probably give up. I gave myself a free pass cuz of what happened but I am not trying to do anything illegal. UPX was installed thanks to you guys but of course, that file path isn't correct so I need to figure out where to find the correct file path is – Tyler62515 Nov 17 '17 at 1:34
  • Yes .exe extension file like in Windows. – Tyler62515 Nov 17 '17 at 1:36
2

It's not clear to me what commands you actually entered into the Terminal, but based on the output, it looks like they were not entered correctly.

brew install upx

This is one command. It instructs brew to install the command-line program upx. It needs to be entered on its own line, after which you press enter.

upx -d "/Applications/Ableton Live 9 Suite.app/Contents/MacOS/Ableton Live 9 Suite"

This is the second command. It tells the program upx to do something to the file at the path specified, with the -d option switch. It assumes your Ableton installation exists on that exact path /Applications/Ableton Live 9 Suite.app/Contents/MacOS/Ableton Live 9 Suite with that exact name. I'm not familiar with upx, so I assume that you're using the correct syntax for that program's execution.

The $ in the command you copied are shell prompts, and not part of the actual commands.

  • 1
    Shell paths in commands require either double quotes or backslashes in the path if spaces are present. /Applications/Ableton\ Live\ 9\ Suite.app/Contents/MacOS/Ableton\ Live\ 9\ Suite – Jahhein Nov 15 '17 at 17:52
  • Thank you for replying vykor. It was very helpful and it worked. I now need to find the correct file path. – Tyler62515 Nov 17 '17 at 1:37
1

Based on what I could understand you managed to install homebrew properly based on the error output. Your problem seems to be what you entered into the terminal as commands.

The symbol in terminal commands $ is to refer to the start of a command and is not to be copied and used in the command.

Example: $ brew install upx

should be entered: brew install upx

What happened here is brew tried searching and installing a packaged called $ after it looked for upx and since it never found the package by the name $ , as it doesn't exist, it never installed anything.

I'm not able to go through the package upx manual pages to figure out if your upx commands are correct, but if they are, what you need to do is the following to install upx via the brew command. Type or copy and paste each command and hit enter.

brew install upx

Then enter this second command...

upx -d "/Applications/Ableton Live 9 Suite.app/Contents/MacOS/Ableton Live 9 Suite"

And all in one copy and paste if this confuses anyone (a ; means the start of a new, seperate command):

brew install upx; upx -d "/Applications/Ableton Live 9 Suite.app/Contents/MacOS/Ableton Live 9 Suite"

Also note: commands via the terminal are not code. They are individual commands that you type to be carried out on by one. The command exit exits the shell and won't let you input more commands without starting a new Terminal.app window/tab. (If it didn't close out the app window completely, which it doesn't by default.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .